<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta http-equiv="x-ua-compatible" content="ie=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://nakedsecurity.sophos.com/xmlrpc.php">
<script type='text/javascript'>
var _vwo_code=(function(){
var account_id=25349,
settings_tolerance=2000,
library_tolerance=2500,
use_existing_jquery=false,
/* DO NOT EDIT BELOW THIS LINE */
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
</script>

<meta name="description" content="The bot scraped Venmo&#039;s public API for sex, drugs and alcohol-related words, then tweeted profile photos and first names of the &quot;buyers.&quot;" />
<meta name="keywords" content="privacy, twitter, bots, paypal, twitter, venmo" />
<title>Names and photos of Venmo &#8216;drug buyers&#8217; published on Twitter &#8211; Naked Security</title>
<meta name="google-site-verification" content="I9dHFo-YhnK2MfAHn-20V4GnWrOttVUYyISGamyU41M" />
<meta name="msvalidate.01" content="7D8D1FA2892142B1543D2CBCD07FB88F" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=nakedsecurity.sophos.com&amp;id=15254721&amp;t=1532489449&amp;back=https%3A%2F%2Fnakedsecurity.sophos.com%2F2018%2F07%2F24%2Fnames-and-photos-of-venmo-drug-buyers-published-on-twitter%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//sophosnews.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Naked Security &raquo; Feed" href="https://nakedsecurity.sophos.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Naked Security &raquo; Comments Feed" href="https://nakedsecurity.sophos.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Naked Security &raquo; Names and photos of Venmo &#8216;drug buyers&#8217; published on Twitter Comments Feed" href="https://nakedsecurity.sophos.com/2018/07/24/names-and-photos-of-venmo-drug-buyers-published-on-twitter/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
	<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJyNkd1uwyAMhV9ojCVbpt5MexagLnFrMIpJ0779SFE0dT+oN+gccz6wQS9JOY4ZYtZhVolmj1H0khwHJQEJrj/csxN50n9jhCcQfYScjDupm2vFHU9Q6iGZvCYC7NEAQSixFrbg3kMuuGxaZbg0kZDet4tWOZb2mp3Via1NE4iosgacg8pj6e03V8v6jEkLp5ElwiKqf+kGLflK8MgsB+PAMtdHs3x5nBR2aEhhidybCqOOnOvmJlqnemBF7ExGjndGHcjg1EInsMS+SH/7mW/734ONb9oTW0Nr4DN8dMNrt+uHXdcfvwBn5PiG?cssminify=yes' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyFztEKwjAMBdAfsquTiXsRv6XWOFKXtDbphn69HeiDMBQCgdzDJXZOBtmP5QJiQ517gfx4rybIxv4ChnDITqEh5A/2kRVYF0vxjCOYIpDdUG+16BpXXIqiBCIVraTfLyFPCPNfFkCT8zeTQfC5tJ7o2Hb9Yde3+24bXjRNW9I='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1530132353h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://sophosnews.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://wp.me/p120rT-1JaD' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fnakedsecurity.sophos.com%2F2018%2F07%2F24%2Fnames-and-photos-of-venmo-drug-buyers-published-on-twitter%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fnakedsecurity.sophos.com%2F2018%2F07%2F24%2Fnames-and-photos-of-venmo-drug-buyers-published-on-twitter%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Names and photos of Venmo &#8216;drug buyers&#8217; published on Twitter" />
<meta property="og:url" content="https://nakedsecurity.sophos.com/2018/07/24/names-and-photos-of-venmo-drug-buyers-published-on-twitter/" />
<meta property="og:description" content="The bot scraped Venmo&#8217;s public API for sex, drugs and alcohol-related words, then tweeted profile photos and first names of the &#8220;buyers.&#8221;" />
<meta property="article:published_time" content="2018-07-24T11:35:10+00:00" />
<meta property="article:modified_time" content="2018-07-24T11:35:10+00:00" />
<meta property="og:site_name" content="Naked Security" />
<meta property="og:image" content="https://sophosnews.files.wordpress.com/2018/07/shutterstock_496300243-compressor.jpg?w=640" />
<meta property="og:image:secure_url" content="https://sophosnews.files.wordpress.com/2018/07/shutterstock_496300243-compressor.jpg?w=640" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="334" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@NakedSecurity" />
<meta name="twitter:text:title" content="Names and photos of Venmo &#8216;drug buyers&#8217; published on Twitter" />
<meta name="twitter:image" content="https://sophosnews.files.wordpress.com/2018/07/shutterstock_496300243-compressor.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@NakedSecurity" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<meta property="fb:admins" content="28552295016" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/36cdcb4bed050e19e465471a6bbe63b0?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/36cdcb4bed050e19e465471a6bbe63b0?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="https://secure.gravatar.com/blavatar/36cdcb4bed050e19e465471a6bbe63b0?s=114" />
<link rel='openid.server' href='https://sophosnews.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://sophosnews.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://nakedsecurity.sophos.com/osd.xml" title="Naked Security" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<link rel="canonical" href="https://nakedsecurity.sophos.com/2018/07/24/names-and-photos-of-venmo-drug-buyers-published-on-twitter/">		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<link rel="author" href="https://plus.google.com/117177061085784456426" />
<meta name="application-name" content="Naked Security" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Computer Security News, Advice and Research" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://nakedsecurity.sophos.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/36cdcb4bed050e19e465471a6bbe63b0?s=16" /><link rel="amphtml" href="https://nakedsecurity.sophos.com/2018/07/24/names-and-photos-of-venmo-drug-buyers-published-on-twitter/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>
</head>

<body class="post-template-default single single-post postid-411967 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light" >
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	
	<header id="masthead" class="site-header" role="banner">
		<div class="header-container">
			<div class="site-branding">
				<h1 class="site-title"><a class="site-logo" href="https://nakedsecurity.sophos.com/" rel="home">Naked Security</a></h1>
				<div class="site-description">Computer Security News, Advice and Research</div>
			</div><!-- .site-branding -->

			<nav id="site-navigation" class="main-navigation" role="navigation">
				<div class="container">
					<ul id="menu-main-menu" class="exit-links menu"><li id="menu-item-306596" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-306596"><a href="https://www.sophos.com/">sophos.com</a></li>
<li id="menu-item-306597" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-306597"><a href="https://www.sophos.com/en-us/products/free-tools.aspx">Free Tools</a></li>
<li id="menu-item-396356" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-396356"><a href="https://nakedsecurity.sophos.com/2018/02/06/20-off-sophos-home-premium-because-youre-not-just-it-at-work/">20% off Sophos Home</a></li>
</ul>				</div>
			</nav><!-- #site-navigation -->

			<a href="#" id="search-toggle" class="search-toggle"></a>
			<div class="site-search-block">
	<form role="search" class="search-form" method="get" action="https://nakedsecurity.sophos.com/">
        <fieldset>
            <div class="field">
				<input type="search" value="" name="s" class="search-field" placeholder="Search naked security...">
            </div>
            <div class="submit">
				<button type="submit" class="search-submit button">Go</button>
            </div>
        </fieldset>
    </form>
</div>
					</div><!-- .container -->
	</header><!-- #masthead -->

	
	<section class="about-panel">
	<div class="container">
	<div class="panel-content ">

		<div class="description">Award-winning computer security news</div>
	<ul class="social-links">
	<li class="twitter">
		<a rel="nofollow" href="https://twitter.com/#!/NakedSecurity" title="Follow our team of security experts on Twitter">Twitter</a>
	</li>
	<li class="facebook">
		<a rel="nofollow" href="https://www.facebook.com/SophosSecurity" title="Join over 250,000 people in our Facebook community">Facebook</a>
	</li>
	<li class="google">
		<a rel="nofollow" href="https://plus.google.com/107512733802574023624" title="Join our Google+ community">Google+</a>
	</li>
	<li class="linkedin">
		<a rel="nofollow" href="https://www.linkedin.com/company/5053/" title="Join the naked security discussion group on LinkedIn">LinkedIn</a>
	</li>
	<li class="rss">
		<a rel="nofollow" href="/feed" title="Subscribe to our RSS feed">Feed</a>
	</li>
</ul>

	</div> <!-- .panel-container -->
	</div> <!-- .container -->
	</section> <!-- .panel -->

	
	<div id="content" class="site-content">
		<div class="content-container">

</div> <!-- .container -->
</div> <!-- #content -->


	<section class="content-panel">
	<div class="container">
	<div class="panel-content framed-content-area">

		<main id="main" class="site-main" role="main">

	
		
<article id="post-411967" class="post-411967 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-privacy category-twitter tag-bots tag-paypal tag-twitter tag-venmo">

	<header class="entry-header">
		<h1 class="entry-title">Names and photos of Venmo &#8216;drug buyers&#8217; published on Twitter</h1>		<div class="entry-meta">
			<div>
				
	<span class="entry-published">
		<time class="entry-date published" datetime="2018-07-24T12:35:10+00:00">24 Jul 2018</time>
	</span>

					<a href="#comments" class="comment-box">
					<span class="count">0</span>
				</a>
					
	<span class="entry-categories">
	<a href="https://nakedsecurity.sophos.com/category/privacy/">Privacy</a>, <a href="https://nakedsecurity.sophos.com/category/social-networks/twitter/">Twitter</a>	</span>

			</div>
	</header> <!-- .entry-header -->

    <div id="newsletter-signup" class="container top"></div>

			<div class="entry-featured-image">
			<img width="780" height="408" src="https://sophosnews.files.wordpress.com/2018/07/shutterstock_496300243-compressor.jpg?w=780&amp;h=408&amp;crop=1" class="attachment-hero-thumbnail size-hero-thumbnail wp-post-image" alt="" srcset="https://sophosnews.files.wordpress.com/2018/07/shutterstock_496300243-compressor.jpg?w=780&amp;h=408&amp;crop=1 780w, https://sophosnews.files.wordpress.com/2018/07/shutterstock_496300243-compressor.jpg?w=150&amp;h=78&amp;crop=1 150w, https://sophosnews.files.wordpress.com/2018/07/shutterstock_496300243-compressor.jpg?w=300&amp;h=157&amp;crop=1 300w, https://sophosnews.files.wordpress.com/2018/07/shutterstock_496300243-compressor.jpg?w=768&amp;h=401&amp;crop=1 768w, https://sophosnews.files.wordpress.com/2018/07/shutterstock_496300243-compressor.jpg?w=1024&amp;h=535&amp;crop=1 1024w, https://sophosnews.files.wordpress.com/2018/07/shutterstock_496300243-compressor.jpg 1200w" sizes="(max-width: 780px) 100vw, 780px" data-attachment-id="411978" data-permalink="https://nakedsecurity.sophos.com/2018/07/24/names-and-photos-of-venmo-drug-buyers-published-on-twitter/shutterstock_496300243-compressor/" data-orig-file="https://sophosnews.files.wordpress.com/2018/07/shutterstock_496300243-compressor.jpg" data-orig-size="1200,627" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="shutterstock_496300243-compressor" data-image-description="" data-medium-file="https://sophosnews.files.wordpress.com/2018/07/shutterstock_496300243-compressor.jpg?w=300" data-large-file="https://sophosnews.files.wordpress.com/2018/07/shutterstock_496300243-compressor.jpg?w=640" />					</div> <!-- .entry-featured-image -->
		
		<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>

		<div class="nav-links">
			<div class="nav-previous"><a href="https://nakedsecurity.sophos.com/2018/07/24/google-hasnt-suffered-an-employee-phishing-compromise-in-over-a-year/" rel="prev"><span class="nav-label">Previous</span><span class="nav-seperator">:</span><span class="nav-title"> Google hasn&#8217;t suffered an employee phishing compromise in over a year</span></a></div><div class="nav-next"><a href="https://nakedsecurity.sophos.com/2018/07/24/the-bluetooth-device-snooping-bug-what-you-need-to-know/" rel="next"><span class="nav-label">Next</span><span class="nav-seperator">:</span><span class="nav-title"> The Bluetooth &#8220;device snooping bug&#8221; &#8211; what you need to know</span></a></div>		</div>
		<!-- .nav-links -->
	</nav><!-- .navigation -->
	
	<div class="entry-content">
		<div class="entry-prefix">
			<div class="entry-author">
				
	
					<span class="by">by</span>
			<a href="https://nakedsecurity.sophos.com/author/lisa-vaas/" title="Posts by Lisa Vaas" class="author url fn" rel="author">Lisa Vaas</a>		
	
			
			</div>
			<div class="entry-sharing">
				
	<ul class="social-links article-social-links">
		<li class="facebook"><a href="https://www.facebook.com/share.php?u=https%3A%2F%2Fnakedsecurity.sophos.com%2F2018%2F07%2F24%2Fnames-and-photos-of-venmo-drug-buyers-published-on-twitter%2F&title=Names+and+photos+of+Venmo+%E2%80%98drug+buyers%E2%80%99+published+on+Twitter" data-title="Names and photos of Venmo ‘drug buyers’ published on Twitter" title="Share on Facebook"><span class="share-count" data-url="https://nakedsecurity.sophos.com/2018/07/24/names-and-photos-of-venmo-drug-buyers-published-on-twitter/">0</span>Share on Facebook</a></li>
		<li class="twitter"><a href="https://twitter.com/home?status=Names+and+photos+of+Venmo+%E2%80%98drug+buyers%E2%80%99+published+on+Twitter+https%3A%2F%2Fwp.me%2Fp120rT-1JaD" data-title="Names and photos of Venmo &#8216;drug buyers&#8217; published on Twitter" title="Share on Twitter">Share on Twitter</a></li>
		<li class="google"><a href="https://plus.google.com/share?url=https%3A%2F%2Fwp.me%2Fp120rT-1JaD" data-title="Names and photos of Venmo ‘drug buyers’ published on Twitter" title="Share on Google+">Share on Google+</a></li>
		<li class="linkedin"><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwp.me%2Fp120rT-1JaD&title=Names+and+photos+of+Venmo+%E2%80%98drug+buyers%E2%80%99+published+on+Twitter" data-title="Names and photos of Venmo ‘drug buyers’ published on Twitter" title="Share on LinkedIn">Share on LinkedIn</a></li>
		<li class="reddit"><a href="https://reddit.com/submit/?url=https%3A%2F%2Fwp.me%2Fp120rT-1JaD&title=Names+and+photos+of+Venmo+%E2%80%98drug+buyers%E2%80%99+published+on+Twitter" title="Share on Reddit">Share on Reddit</a></li>

			</ul>

				</div>
		</div>
		<p>There are a few options available to get people&#8217;s attention when you find their really, really personal information dribbled onto the web for anybody to see.</p>
<p>For one, you could pull it all together and publish it in a nice, sober, insightful analysis that anonymizes all their <a title="Naked Security: Venmo users: time to hide your drug deals and excessive pizza consumption" href="https://nakedsecurity.sophos.com/2018/07/19/venmo-users-time-to-hide-your-drug-deals-and-excessive-pizza-consumption/">Venmo drug purchases</a> and pizza-eating habits. Or, another option is to whip up a bot to automatically tweet out the profile photos of anybody making those drug deals&#8230;</p>
<p>&#8230;or, to be more specific, the profile photos and first names of people whose public-by-default Venmo transactions include words such as heroin, marijuana, cocaine, meth or speed; emojis that denote drugs; or non-drug-related words such as sex, porn or hookers.</p>
<p>As we wrote about last week, researcher <a title="Naked Security: Venmo users: time to hide your drug deals and excessive pizza consumption" href="https://nakedsecurity.sophos.com/2018/07/19/venmo-users-time-to-hide-your-drug-deals-and-excessive-pizza-consumption/">Hang Do Thi Duc took the analysis route</a>, scraping a year&#8217;s worth of data from Venmo&#8217;s public API to find out what people are buying, who they&#8217;re sending money to, why they&#8217;re sending money, first and last names, profile pictures, times of the transactions, messages attached to the transactions, and more. Using 207,984,218 transactions, she chronicled Venmo users&#8217; lives, everything from cannabis sales to budding romances and breakups, and eating habits.</p>
<p>She wanted to make it clear that anybody can find out a whole lot about you if you don&#8217;t make your Venmo account private. To do so, she used the gentle touch of anonymized data.</p>
<p>Joel Guerra, the creator of the <a title="Twitter: @venmodrugs" href="https://twitter.com/venmodrugs/" rel="nofollow">Who&#8217;s buying drugs on Venmo? bot,</a> got a little more slap-happy when he got his hands on Venmo&#8217;s public API. As he <a title="Medium: Why I Blasted Your “Drug” Deals on Twitter" href="https://blog.usejournal.com/why-i-blasted-your-drug-deals-on-twitter-f8c517de1256" rel="nofollow">explained</a> in a post on Medium, when Guerra saw the endpoint to Venmo&#8217;s API had been posted publicly on Twitter, he quickly did &#8220;what any software engineer would do&#8221;: he started digging through the data.</p>
<p>Ah, he realized: I&#8217;m not the only one who likes to put salacious nonsense in Venmo&#8217;s transaction description field.</p>
<blockquote><p>I thought about the many times I had filled that out myself with joke descriptions like “baby oil backrub” or “plan B pills” when splitting restaurant tabs with friends.</p></blockquote>
<p>The key difference: Guerra&#8217;s Venmo account has his transactions set to &#8220;private&#8221; to ensure that he&#8217;s not spewing his baby oil backrubs all over the place.</p>
<p>Venmo’s default setting is public, for whatever &#8220;we also want to be a social app&#8221; reasons there might be. Don&#8217;t like it? You shouldn&#8217;t, unless you like the idea of somebody such as Guerra coming along and tweeting out your transactions, along with your profile picture, name, and any other information Venmo makes public by default. If you don&#8217;t like the thought of that prospect, you can change your privacy settings.</p>
<p>Guerra wanted to do something fun to call people&#8217;s attention to the lack of privacy in Venmo&#8217;s default settings, so he whipped up a 70-line Python script and made a new Twitter account. Then, he set it free. For about 24 hours, his script diligently, automatically tweeted the first names and profile pictures of users making “drug” transactions on Venmo.</p>
<blockquote><p>I chose drugs, sex and alcohol keywords as the trigger for the bot because they were funny and shocking. I removed the last names of users because I didn’t want to actually contribute to the problem of lack of privacy.</p></blockquote>
<p>The transactions aren&#8217;t, necessarily, actual drug deals. In fact, most aren&#8217;t, Guerra told <a title="Motherboard Vice: This Bot Tweets Photos and Names of People Who Bought 'Drugs' on Venmo" href="https://motherboard.vice.com/en_us/article/qvmkvx/twitter-bot-venmo-buying-drugs-photo-names" rel="nofollow">Motherboard.</a> Rather, Guerra believes that he caught a net-full of tongue-in-cheek transaction descriptions, on par with his Plan B pills.</p>
<p>Either that, or the simple Python script took things out of context. For example, one transaction posted on Thursday included the message “Your love is my drug.” The profile picture showed the user with somebody who could have been a spouse or significant other.</p>
<aside id="sophos_ad-10" class="widget sophos-inline-ad sophos_widget_ad">				<style></style>
				<div class="sophos_widget_ad"><a data-ga-label="Sophos Home - Stop ransomeware without lifting a finger (Free)" href="https://home.sophos.com?cmp=27313" class="s-ad-sophos-home-v2__link-wrapper"><div class="s-ad-sophos-home-v2"><div class="s-ad-sophos-home-v2__logo"><div class="s-ad-sophos-home-v2__logo-svg"></div></div><div class="s-ad-sophos-home-v2__content"><div class="s-ad-sophos-home-v2__title">Free award-winning computer security</div><div class="s-ad-sophos-home-v2__text">Stop ransomware without lifting a finger</div></div></div></a></div>
			</aside>
<p>Another message read &#8220;not drugs,&#8221; while yet another contained the phrase &#8220;Funding for your Scotland &amp; Ireland trip. God speed,&#8221; with the script presumably only plucking the word &#8220;speed&#8221; out of context.</p>
<p>As Guerra said in his Medium post, the response to his &#8220;Who&#8217;s buying drugs on Venmo?&#8221; tweets was overwhelmingly positive. People heard his privacy message loud and clear. But even if we all got it, we didn&#8217;t all like it. Just because data is public doesn&#8217;t mean that more exposure will make things better. In fact, it makes things worse.</p>
<p>As Motherboard&#8217;s Joseph Cox notes, there are plenty of examples of researchers and coders who&#8217;ve scraped sites for publicly available data and then handled the data in ways that have rubbed people the wrong way.</p>
<p>One example: in 2016, without users’ permission, Danish researchers publicly released data scraped from <a title="Naked Security: Published personal data on 70,000 OkCupid users taken down after DMCA order" href="https://nakedsecurity.sophos.com/2016/05/20/published-personal-data-on-70000-okcupid-users-taken-down-after-dmca-order/">70,000 OkCupid profiles</a>, including their usernames, age, gender, location, what kind of relationship (or sex) they’re interested in, personality traits and answers to thousands of profiling questions used by the site.</p>
<p>On Friday, after getting &#8220;more attention than [he] had imagined possible,&#8221; Guerra shut down the script.</p>
<blockquote><p>I saw no further value in tweeting out anyone’s personal transactions anymore.</p></blockquote>
<p>But just because he&#8217;s not sniffing around for public mentions of meth or hookers anymore doesn&#8217;t mean they&#8217;re not out there. He invited us all to have a peek to see for ourselves at Venmo’s API:</p>
<blockquote><p>You’ll see all the details of the last one thousand Venmo transactions including last names and usernames that I chose not to include in my bot’s tweets.</p></blockquote>
<p>Or, then again, maybe we shouldn&#8217;t look at that public API. Maybe instead, check your own account, and please do advise your friends if you think they need to zip up their Venmo pants.</p>
<p style="padding-bottom:0;padding-top:.71em;"><a href="https://twitter.com/LisaVaas" class="twitter-follow-button">Follow @LisaVaas</a><br />
<a href="https://twitter.com/NakedSecurity" class="twitter-follow-button">Follow @NakedSecurity</a></p>
<p style="padding-bottom:0;padding-top:.71em;">
			</div> <!-- .entry-content -->
    
	<div id="newsletter-signup" class="container middle"></div>

</article><!-- #post-## -->

		
	<div class="entry-tags">
		<ul><li><a href="https://nakedsecurity.sophos.com/tag/bots/" rel="tag">bots</a></li><li><a href="https://nakedsecurity.sophos.com/tag/paypal/" rel="tag">PayPal</a></li><li><a href="https://nakedsecurity.sophos.com/tag/twitter/" rel="tag">Twitter</a></li><li><a href="https://nakedsecurity.sophos.com/tag/venmo/" rel="tag">Venmo</a></li></ul>	</div>

	
		<div class="free-tools-block">
			<h2 class="tools-title">Free tools</h2>
<div class="tools-collection">
	<div class="tool-item">
		<a class="tool-link" href="https://www.sophos.com/en-us/lp/sophos-home.aspx?cmp=701j0000001eLpnAAE">
			<img src="https://s2.wp.com/wp-content/themes/vip/sophosnews-2015/img/free-tools/sophos-home@2x.png" alt="Sophos Home" class="tool-image" width="100" height="70">
			<h4 class="tool-title">Sophos Home<br>for Windows and Mac</h4>
		</a>
	</div>
	<div class="tool-item">
		<a class="tool-link" href="https://www.hitmanpro.com/en-us/hmp.aspx">
			<img src="https://s2.wp.com/wp-content/themes/vip/sophosnews-2015/img/free-tools/hitman-pro@2x.png" alt="Hitman Pro" class="tool-image" width="100" height="70">
			<h4 class="tool-title">Hitman Pro<br>&nbsp;</h4>
		</a>
	</div>
	<div class="tool-item">
		<a class="tool-link" href="https://www.sophos.com/en-us/products/free-tools/sophos-mobile-security-free-edition.aspx">
			<img src="https://s2.wp.com/wp-content/themes/vip/sophosnews-2015/img/free-tools/mobile-security-android@2x.png" alt="Sophos Mobile Security for Android" class="tool-image" width="100" height="70">
			<h4 class="tool-title">Sophos Mobile Security<br>for Android</h4>
		</a>
	</div>
	<div class="tool-item">
		<a class="tool-link" href="https://www.sophos.com/en-us/products/free-tools/virus-removal-tool.aspx">
			<img src="https://s2.wp.com/wp-content/themes/vip/sophosnews-2015/img/free-tools/virus-removal@2x.png" alt="Virus Removal Tool" class="tool-image" width="100" height="70">
			<h4 class="tool-title">Virus Removal Tool</h4>
		</a>
	</div>
	<div class="tool-item">
		<a class="tool-link" href="https://www.sophos.com/en-us/products/free-tools/sophos-antivirus-for-linux.aspx">
			<img src="https://s2.wp.com/wp-content/themes/vip/sophosnews-2015/img/free-tools/antivirus-linux@2x.png" alt="Antivirus for Linux" class="tool-image" width="100" height="70">
			<h4 class="tool-title">Antivirus<br>for Linux</h4>
		</a>
	</div>
</div>
		</div>

			<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>

		<div class="nav-links">
			<div class="nav-previous"><a href="https://nakedsecurity.sophos.com/2018/07/24/google-hasnt-suffered-an-employee-phishing-compromise-in-over-a-year/" rel="prev"><span class="nav-label">Previous</span><span class="nav-seperator">:</span><span class="nav-title"> Google hasn&#8217;t suffered an employee phishing compromise in over a year</span></a></div><div class="nav-next"><a href="https://nakedsecurity.sophos.com/2018/07/24/the-bluetooth-device-snooping-bug-what-you-need-to-know/" rel="next"><span class="nav-label">Next</span><span class="nav-seperator">:</span><span class="nav-title"> The Bluetooth &#8220;device snooping bug&#8221; &#8211; what you need to know</span></a></div>		</div>
		<!-- .nav-links -->
	</nav><!-- .navigation -->
	
	
	</main><!-- #main -->

	</div> <!-- .panel-container -->
	</div> <!-- .container -->
	</section> <!-- .panel -->

	

	<section class="expert-panel">
	<div class="container">
	<div class="panel-content framed-content-area">

	 	<h3 class="block-title">
 		 			About the author 		 	</h3>
	<div class="article-author-block article-co-authors-block">
	<div class="author-profile">
		<img width="200" height="200" src="https://sophosnews.files.wordpress.com/2018/02/lisa-vaas.jpg?w=200" class="avatar avatar-200 photo wp-post-image" alt="Lisa Vaas" />	</div> <!-- .author-profile -->
	<div class="author-description">
					<h3 class="author-name"><a href="https://nakedsecurity.sophos.com/author/lisa-vaas/" title="Posts by Lisa Vaas" class="author url fn" rel="author">Lisa Vaas</a></h3>
				<p class="author-bio">Lisa has been writing about technology, careers, science and health since 1995. She rose to the lofty heights of Executive Editor for eWEEK, popped out with the 2008 crash and joined the freelancer economy. Alongside Naked Security Lisa has written for CIO Mag, ComputerWorld, PC Mag, IT Expert Voice, Software Quality Connection, Time, and the US and British editions of HP&#039;s Input/Output.</p>
	</div> <!-- .author-description -->
</div>

	</div> <!-- .panel-container -->
	</div> <!-- .container -->
	</section> <!-- .panel -->

	
<div id="newsletter-signup" class="container bottom"></div>

	
	<section class="comments-panel">
	<div class="container">
	<div class="panel-content ">

			
<div id="comments" class="comments-area">

	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/07/24/names-and-photos-of-venmo-drug-buyers-published-on-twitter/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://nakedsecurity.sophos.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="80a8c417e2" /><input type="hidden" name="_wp_http_referer" value="/2018/07/24/names-and-photos-of-venmo-drug-buyers-published-on-twitter/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">
	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" class="nascar-signin-link"
                   title="Login via Guest">
									</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" class="nascar-signin-link"
                   title="Login via WordPress.com">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg>				</a>
			</li>
			<li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" class="nascar-signin-link"
                   title="Login via Twitter">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" class="nascar-signin-link"
                   title="Login via Facebook">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg>				</a>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name</label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
			
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
						<p class="comment-form-posting-as pa-wordpress">
			<strong></strong>
			You are commenting using your WordPress.com account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
						<p class="comment-form-posting-as pa-googleplus">
			<strong></strong>
			You are commenting using your Google+ account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" x="0px" y="0px" viewBox="0 0 60 60" ><path fill="#519bf7" d="M56.3,30c0,-1.6 -0.2,-3.4 -0.6,-5h-3.1H42.2H30v10.6h14.8C44,39.3 42,42 39.1,43.9l8.8,6.8C53,46 56.3,39 56.3,30z" /><path fill="#3db366" d="M30,57.5c6.7,0 13.1,-2.4 17.9,-6.8l-8.8,-6.8c-2.5,1.6 -5.6,2.4 -9.1,2.4c-7.2,0 -13.3,-4.7 -15.4,-11.2l-9.3,7.1C9.8,51.3 19.1,57.5 30,57.5z" /><path fill="#fdc600" d="M5.3,42.2l9.3,-7.1c-0.5,-1.6 -0.8,-3.3 -0.8,-5.1s0.3,-3.5 0.8,-5.1l-9.3,-7.1C3.5,21.5 2.5,25.6 2.5,30S3.5,38.5 5.3,42.2z" /><path fill="#f15b44" d="M40.1,17.4l8,-8C43.3,5.1 37,2.5 30,2.5C19.1,2.5 9.8,8.7 5.3,17.8l9.3,7.1c2.1,-6.5 8.2,-11.1 15.4,-11.1C33.9,13.7 37.4,15.1 40.1,17.4z" /></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
						<p class="comment-form-posting-as pa-twitter">
			<strong></strong>
			You are commenting using your Twitter account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
						<p class="comment-form-posting-as pa-facebook">
			<strong></strong>
			You are commenting using your Facebook account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg></span>
		</p>
		w
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	</div>





<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='411967' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="a90b978dbe" /></p>
<input type="hidden" name="genseq" value="1532489449" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="180"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>
</div><!-- #comments -->
		<div class="comments-widget-area">
					</div>
	
	</div> <!-- .panel-container -->
	</div> <!-- .container -->
	</section> <!-- .panel -->

	

	<section class="recommended-panel">
	<div class="container">
	<div class="panel-content ">

		<h3 class="block-title">Recommended reads</h3>
	<div class="card-collection">
		<article id="post-411631" class="card-slide">
	<div class="card-image">
		<div class="image-pointer"></div>
		<a href="https://nakedsecurity.sophos.com/2018/07/19/venmo-users-time-to-hide-your-drug-deals-and-excessive-pizza-consumption/">
	<div class="dynamic-image-frame">
		<div class="dynamic-image" style="background-image: url('https://sophosnews.files.wordpress.com/2018/07/shutterstock_1109551547-compressor.jpg?w=412&#038;h=200&#038;crop=1');"></div>
	</div>

	</a>
	</div>
	<div class="card-content">
		<div class="meta-box">
			<div class="date-box">
				<span class="month">Jul</span><span class="day">19</span>
			</div>
 			<div class="author-box">
			<span class="by">by</span>
		John E Dunn	
	</div>
			<div class="comment-box">
				<span class="count">4</span>
			</div>
		</div>
		<h3 class="card-title"><a href="https://nakedsecurity.sophos.com/2018/07/19/venmo-users-time-to-hide-your-drug-deals-and-excessive-pizza-consumption/" rel="bookmark">Venmo users: time to hide your drug deals and excessive pizza consumption</a></h3>	</div>
</article> <!-- .card-article -->
<article id="post-402506" class="card-slide">
	<div class="card-image">
		<div class="image-pointer"></div>
		<a href="https://nakedsecurity.sophos.com/2018/04/05/facebook-and-twitter-may-be-forced-to-identify-bots/">
	<div class="dynamic-image-frame">
		<div class="dynamic-image" style="background-image: url('https://sophosnews.files.wordpress.com/2018/04/shutterstock_462555613.jpg?w=412&#038;h=200&#038;crop=1');"></div>
	</div>

	</a>
	</div>
	<div class="card-content">
		<div class="meta-box">
			<div class="date-box">
				<span class="month">Apr</span><span class="day">05</span>
			</div>
 			<div class="author-box">
			<span class="by">by</span>
		Lisa Vaas	
	</div>
			<div class="comment-box">
				<span class="count">8</span>
			</div>
		</div>
		<h3 class="card-title"><a href="https://nakedsecurity.sophos.com/2018/04/05/facebook-and-twitter-may-be-forced-to-identify-bots/" rel="bookmark">Facebook and Twitter may be forced to identify bots</a></h3>	</div>
</article> <!-- .card-article -->
<article id="post-400204" class="card-slide">
	<div class="card-image">
		<div class="image-pointer"></div>
		<a href="https://nakedsecurity.sophos.com/2018/03/12/fake-news-travels-faster-than-truth-on-twitter-and-we-cant-blame-bots/">
	<div class="dynamic-image-frame">
		<div class="dynamic-image" style="background-image: url('https://sophosnews.files.wordpress.com/2018/03/shutterstock_540977206.jpg?w=412&#038;h=200&#038;crop=1');"></div>
	</div>

	</a>
	</div>
	<div class="card-content">
		<div class="meta-box">
			<div class="date-box">
				<span class="month">Mar</span><span class="day">12</span>
			</div>
 			<div class="author-box">
			<span class="by">by</span>
		Lisa Vaas	
	</div>
			<div class="comment-box">
				<span class="count">19</span>
			</div>
		</div>
		<h3 class="card-title"><a href="https://nakedsecurity.sophos.com/2018/03/12/fake-news-travels-faster-than-truth-on-twitter-and-we-cant-blame-bots/" rel="bookmark">Fake news travels faster than truth on Twitter, and we can&#8217;t blame bots</a></h3>	</div>
</article> <!-- .card-article -->
<article id="post-398831" class="card-slide">
	<div class="card-image">
		<div class="image-pointer"></div>
		<a href="https://nakedsecurity.sophos.com/2018/02/23/5-signs-you-may-be-talking-to-a-bot/">
	<div class="dynamic-image-frame">
		<div class="dynamic-image" style="background-image: url('https://sophosnews.files.wordpress.com/2018/02/shutterstock_434970346.jpg?w=412&#038;h=200&#038;crop=1');"></div>
	</div>

	</a>
	</div>
	<div class="card-content">
		<div class="meta-box">
			<div class="date-box">
				<span class="month">Feb</span><span class="day">23</span>
			</div>
 			<div class="author-box">
			<span class="by">by</span>
		Maria Varmazis	
	</div>
			<div class="comment-box">
				<span class="count">6</span>
			</div>
		</div>
		<h3 class="card-title"><a href="https://nakedsecurity.sophos.com/2018/02/23/5-signs-you-may-be-talking-to-a-bot/" rel="bookmark">5 signs you may be talking to a bot</a></h3>	</div>
</article> <!-- .card-article -->
<article id="post-281848" class="card-slide">
	<div class="card-image">
		<div class="image-pointer"></div>
		<a href="https://nakedsecurity.sophos.com/2015/03/03/venmo-mobile-payment-service-under-fire-for-security-carelessness/">
	<div class="dynamic-image-frame">
		<div class="dynamic-image" style="background-image: url('https://sophosnews.files.wordpress.com/2015/03/venmo-250.png?w=250&#038;h=200&#038;crop=1');"></div>
	</div>

	</a>
	</div>
	<div class="card-content">
		<div class="meta-box">
			<div class="date-box">
				<span class="month">Mar</span><span class="day">03</span>
			</div>
 			<div class="author-box">
			<span class="by">by</span>
		John Zorabedian	
	</div>
			<div class="comment-box">
				<span class="count">4</span>
			</div>
		</div>
		<h3 class="card-title"><a href="https://nakedsecurity.sophos.com/2015/03/03/venmo-mobile-payment-service-under-fire-for-security-carelessness/" rel="bookmark">Venmo mobile payment service under fire for security carelessness</a></h3>	</div>
</article> <!-- .card-article -->
<article id="post-280193" class="card-slide">
	<div class="card-image">
		<div class="image-pointer"></div>
		<a href="https://nakedsecurity.sophos.com/2015/02/13/robot-tweets-i-seriously-want-to-kill-people-prompts-police-response/">
	<div class="dynamic-image-frame">
		<div class="dynamic-image" style="background-image: url('https://sophosnews.files.wordpress.com/2015/02/twitter-bot-250_70989490.jpg?w=250&#038;h=200&#038;crop=1');"></div>
	</div>

	</a>
	</div>
	<div class="card-content">
		<div class="meta-box">
			<div class="date-box">
				<span class="month">Feb</span><span class="day">13</span>
			</div>
 			<div class="author-box">
			<span class="by">by</span>
		Lee Munson	
	</div>
			<div class="comment-box">
				<span class="count">13</span>
			</div>
		</div>
		<h3 class="card-title"><a href="https://nakedsecurity.sophos.com/2015/02/13/robot-tweets-i-seriously-want-to-kill-people-prompts-police-response/" rel="bookmark">Robot tweets &#8220;I seriously want to kill people&#8221;, prompts police response</a></h3>	</div>
</article> <!-- .card-article -->
	</div>

	</div> <!-- .panel-container -->
	</div> <!-- .container -->
	</section> <!-- .panel -->

	

	
	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="footer-container">
			<h3 class="sophos-logo">
				<a href="#" class="js-collapse-footer">SOPHOS</a>
			</h3>
			<div id="collapseFooter" class="row">
				<div class="sophos block">
					<ul id="menu-footer-primary" class="primary menu"><li id="menu-item-306737" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-306737"><a href="https://nakedsecurity.sophos.com/about/">About Naked Security</a></li>
<li id="menu-item-306754" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-306754"><a href="https://www.sophos.com/en-us/company.aspx">About Sophos</a></li>
<li id="menu-item-306747" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-306747"><a href="https://nakedsecurity.sophos.com/send-us-a-tip/">Send us a tip</a></li>
<li id="menu-item-323171" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-323171"><a href="/cookies-and-scripts/">Cookies</a></li>
<li id="menu-item-323170" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-323170"><a href="https://www.sophos.com/en-us/legal/sophos-group-privacy-policy.aspx">Privacy</a></li>
<li id="menu-item-323169" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-323169"><a href="https://www.sophos.com/en-us/legal.aspx">Legal</a></li>
</ul>				</div>
				<div class="news block">
					<h4 class="menu-title">Network Protection</h4>
					<ul id="menu-network-protection" class="small menu"><li id="menu-item-306997" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-306997"><a href="https://www.sophos.com/en-us/products/next-gen-firewall.aspx">XG Firewall</a></li>
<li id="menu-item-306998" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-306998"><a href="https://www.sophos.com/en-us/lp/utm-upgrades.aspx">UTM</a></li>
<li id="menu-item-306999" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-306999"><a href="https://www.sophos.com/en-us/products/secure-wifi.aspx">Secure Wi-Fi</a></li>
<li id="menu-item-307000" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307000"><a href="https://www.sophos.com/en-us/products/secure-web-gateway.aspx">Secure Web Gateway</a></li>
<li id="menu-item-307001" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307001"><a href="https://www.sophos.com/en-us/products/secure-email-gateway.aspx">Secure Email Gateway</a></li>
</ul>				</div>
				<div class="products block">
					<h4 class="menu-title">Enduser Protection</h4>
					<ul id="menu-enduser-protection" class="small menu"><li id="menu-item-307002" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307002"><a href="https://www.sophos.com/en-us/products/enduser-protection-suites.aspx">Enduser Protection Bundles</a></li>
<li id="menu-item-307003" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307003"><a href="https://www.sophos.com/en-us/products/endpoint-antivirus.aspx">Endpoint Antivirus</a></li>
<li id="menu-item-307004" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307004"><a href="https://www.sophos.com/en-us/products/cloud.aspx">Sophos Cloud</a></li>
<li id="menu-item-307005" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307005"><a href="https://www.sophos.com/en-us/products/mobile-control.aspx">Mobile Control</a></li>
<li id="menu-item-307006" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307006"><a href="https://www.sophos.com/en-us/products/safeguard-encryption.aspx">SafeGuard Encryption</a></li>
</ul>				</div>
				<div class="threats block">
					<h4 class="menu-title">Server Protection</h4>
					<ul id="menu-server-protection" class="small menu"><li id="menu-item-307007" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307007"><a href="https://www.sophos.com/en-us/products/virtualization-security.aspx">Virtualization Security</a></li>
<li id="menu-item-307008" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307008"><a href="https://www.sophos.com/en-us/products/server-security.aspx">Server Security</a></li>
<li id="menu-item-307009" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307009"><a href="https://www.sophos.com/en-us/products/sharepoint-security.aspx">SharePoint Security</a></li>
<li id="menu-item-307010" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307010"><a href="https://www.sophos.com/en-us/products/network-storage-antivirus.aspx">Network Storage Antivirus</a></li>
<li id="menu-item-307011" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307011"><a href="https://www.sophos.com/en-us/products/puremessage.aspx">PureMessage</a></li>
</ul>				</div>
			</div>
			<ul class="social-links">
	<li class="twitter">
		<a rel="nofollow" href="https://twitter.com/#!/NakedSecurity" title="Follow our team of security experts on Twitter">Twitter</a>
	</li>
	<li class="facebook">
		<a rel="nofollow" href="https://www.facebook.com/SophosSecurity" title="Join over 250,000 people in our Facebook community">Facebook</a>
	</li>
	<li class="google">
		<a rel="nofollow" href="https://plus.google.com/107512733802574023624" title="Join our Google+ community">Google+</a>
	</li>
	<li class="linkedin">
		<a rel="nofollow" href="https://www.linkedin.com/company/5053/" title="Join the naked security discussion group on LinkedIn">LinkedIn</a>
	</li>
	<li class="rss">
		<a rel="nofollow" href="/feed" title="Subscribe to our RSS feed">Feed</a>
	</li>
</ul>

							<div class="vip-powered-wpcom">
					<span class="copyright">© 1997 - 2018 Sophos Ltd.</span>
					All rights reserved.
					Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=nakedsecurity.sophos.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>				</div>
					</div>
		<script type="text/javascript">
			window.cookieconsent_options = {
				"message":"This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies.",
				"dismiss":"Got it!",
				"learnMore":"Learn More",
				"link":"/cookies-and-scripts",
				"theme":"https://s2.wp.com/wp-content/themes/vip/sophosnews-2015/css/sophos.css"};
		</script>
	</footer><!-- #colophon -->
</div><!-- #page -->
<div id="survey-wrapper" class="mfp-hide"><div class="pd-embed" id="pd_1499706777" data-settings=""></div></div>
<!-- wpcom_wp_footer -->
	<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/sophosnews.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/sophosnews.wordpress.com\/wp-login.php?action=logout&_wpnonce=793fc428f2","homeURL":"https:\/\/nakedsecurity.sophos.com\/","postID":"411967","gravDefault":"mystery","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1521806916j'></script>
<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=20111117'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PG8Data = {"startPage":"1","maxPages":"0","nextLink":null};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var Sophos = {"ajaxurl":"https:\/\/nakedsecurity.sophos.com\/wp-admin\/admin-ajax.php","nonce":"4e7ef66077"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyVj9FOwzAMRX8I11uhEzwgPgWliaFJ4yTEScf+nnSaUIVQpb1F8b3Hx3hOoGMoFAo6QUOL1ZS+OycPuBlxheTrpw2C3s4k+FWp0qSC8ZT/hstE3CKLTSgxTVECnQX6w3FYV9w4HdtwX1HHTNuWDdpX0/LXGXMjQKbkL/+hNwc4KknpGd8bAD+UpjHGGYhHMjutHlYtd7UDFZS/FKtlp6BM04BRZWQlhXJ7QVwoZ7s6//7dSSi5qe+una0wFXjsDrcLY+aWf+PX49Cfhuen4fTifgAC27ka'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'15254721','blog_tz':'1','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'15254721','v':'wpcom','tz':'1','user_id':'0','post':'411967','subd':'sophosnews'}]);
function st_vt() {var x=document.createElement("img");x.src="https://pixel.wp.com/g.gif?blog=15254721&v=wpcomvt&tz=1&user_id=0&post=411967&subd=sophosnews&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcwcit4OCtUVUJKW1NvLDRkalEreGI0NnZuTVltZDV2ZHZHbVs/RU5ueSZlK28wYTFlQV9ubkJ1NDY/S1BYdFp1PTNXWzFvVm5QU2xEYzBOWTVlQkN+TzktZVUlcXElR0UtZWVyM2p2aU1pfHxMMUlNQWxhMF1bfDksRmtwekhuZzhxb1EvYjdOdU1nYUZHVlZyYUdaSXZUemJ3QSV4TlpzLCV1PU1zaVB4T2xU'}]);
_stq.push([ 'clickTrackerInit', '15254721', '411967' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>
<!--
	generated 230 seconds ago
	generated in 0.123 seconds
	served from batcache in 0.002 seconds
	expires in 70 seconds
-->
